F9 – пошаговое вычисление формулы в Excel. Бесплатные примеры и статьи.


Динамический выпадающий список в MS EXCEL

При заполнении ячеек данными, бывает необходимо ограничить возможность ввода определенным списком значений – это можно сделать с помощью Выпадающего списка . Если одновременно необходимо обеспечить …

Сложение цифр ЧИСЛА в MS EXCEL

Пусть имеется число 456258 и необходимо найти сумму всех его цифр, т.е. 4+5+6+2+5+8. Сделать это можно одной формулой.

Пошаговый контроль вычисления в MS EXCEL сложных формул

При написании сложных формул, таких как =ЕСЛИ(СРЗНАЧ(A2:A10)>200;СУММ(B2:B10);0) , часто необходимо получить промежуточный результат вычисления формулы. Для этого есть специальный инструмент Вычислить формулу.

Поиск ближайшего события в MS EXCEL

Пусть имеется список неких событий, например, праздников. Найдем ближайшее событие, которое еще не произошло.

Генерируем случайные текстовые значения в MS EXCEL

Если сгенерировать случайное число можно легко с помощью функции СЛУЧМЕЖДУ() , то для генерации текстовых значений нужно изобретать формулу.

Массивы констант в MS EXCEL

Массив значений (или константа массива или массив констант) – это совокупность чисел или текстовых значений, которую можно использовать в формулах массива . Константы массива необходимо …

Поиск последнего повтора в MS EXCEL

Рассмотрим таблицу продаж, состоящую из столбцов Дата продажи и Сумма. Т.к. в день может быть несколько продаж, то столбец с датами содержит повторы. Задав в …

Сортировка списка в MS EXCEL по длине строки

Имеется список (диапазон) с текстовыми значениями, нужно отсортировать его по убыванию длины строки.

Формулы массива в MS EXCEL. Знакомство

Вводная статья для тех, кто никогда не использовал формулы массива.

Формулы массива в MS EXCEL, возвращающие одно значение

Формулы массива могут возвращать как единственное значение, так и несколько значений. В первом случае для отображения результата потребуется одна ячейка, во втором – диапазон. В …

Функция СТОЛБЕЦ() в MS EXCEL

Задача функции СТОЛБЕЦ( ) , английский вариант COLUMN(), - возвращать номер столбца. Формула = СТОЛБЕЦ(B1) вернет 2, т.к. столбец B - второй столбец на листе.

Сортированный список в MS EXCEL (ТЕКСТовые значения)

Сортировку списка можно осуществить через меню Данные/ группа Сортировка и фильтр/ Сортировка . В случае, если в исходный список постоянно вводятся новые значения, то для …

© Copyright 2013 - 2020 Excel2.ru. All Rights Reserved