Функция СТРОКА() в MS EXCEL

Функция СТРОКА(), английский вариант ROW(), вычисляет номер строки, определяемой ссылкой: формула =СТРОКА(B5) вернет 5.

Синтаксис функции

СТРОКА(ссылка)

Ссылка  — ячейка или интервал ячеек, для которых определяется номер строки.

  • Если ссылка опущена, то функция СТРОКА() вернет номер строки в которую введена сама формула. Т.е. если формула =СТРОКА() введена в ячейку B5, то результат будет 5.

  • В аргументе «ссылка» нельзя указывать несколько областей, т.е. запись =СТРОКА(A1:A2;B2:B3) не допустима.

Использование функции в формулах массива

Так как функция СТРОКА() в качестве аргумента позволяет ввести ссылку на диапазон ячеек, то следует ожидать, что она вернет не одно число, а массив целых чисел - соответствующих номеров строк. Для этого введите в Строке формул выражение =СТРОКА(F8:F18). Выделите формулу и нажмите F9 (см. файл примера).

 

Получим массив последовательных чисел {8:9:10:11:12:13:14:15:16:17:18}. Подобные последовательности часто используются в формулах массива (см., например, статью Сложение значений в каждой третьей строке).

Элементы этого массива можно вывести в отдельные ячейки. Для этого выделите диапазон A5:A18, состоящий из 13 ячеек, в Строке формул введите выражение =СТРОКА(F8:F18) как формулу массива, нажав CTRL+SHIFT+ENTER.

Функция СТРОКА() вернула номера строк, указанных в аргументе «ссылка». Т.к. число выделенных ячеек (13) было больше числа строк диапазона F8:F18 (10), то в трех ячейках формула вернула значения ошибки #Н/Д.

Чтобы вывести номера строк в горизонтальном диапазоне используйте формулу =ТРАНСП(СТРОКА(F8:F18)). Не забудьте нажать CTRL+SHIFT+ENTER.

Использование функции для чрезстрочного выделения

Записав в правиле Условного форматирования для диапазона A5:A18 формулу =НЕЧЁТ(СТРОКА())=СТРОКА() получим выделение цветом каждой второй строки (см. рисунок выше).

Формирование списка без повторов

Если список значений содержит повторяющиеся значения (диапазон A21:A34), то функция СТРОКА() может быть использована для формирования списка без повторов. Формула
=ЕСЛИ(ПОИСКПОЗ(A21;$A$21:$A$34;0)=СТРОКА()-СТРОКА($A$20);A21;"")
возвращает значение если оно встречается первый раз.

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 5 (1 оценка)

Комментарии

Игорь (не проверено)

Распишите пожалуйста подробней последние 2 формулы. Не совсем понятно, какую именно функцию выполняет формула СТРОКА.

Creator

Выражение СТРОКА()-СТРОКА($А$20) возвращает номер позиции для каждого значения из диапазона А21:А34, т.е. 1, 2, 3, ...14. Функция ПОИСКПОЗ() возвращает номера позиций только тех значений, которые встречаются первыми сверху. Также можно прочитать статью о формировании списка уникальных значений http://excel2.ru/articles/otbor-unikalnyh-znacheniy-ubiraem-povtory-iz-s...