Подсчет значений с множественными критериями (Часть 4. Два Условия И) в EXCEL

Произведем подсчет значений, удовлетворяющих сразу трем критериям, которые образуют 2 Условия И. Например, в таблице с перечнем Фруктов и их количеством на складе, отберем строки, в которых в столбце Фрукты значится Яблоки, причем с остатком на складе не менее 4 (ящиков) и не более 90.


В качестве исходной таблицы возьмем таблицу с двумя столбцами: текстовым « Фрукты » и числовым « Количество на складе » (См. файл примера ).

Задача

Найдем число партий Яблоки с остатком на складе >=4 И <=90 .

Для удобства строки, удовлетворяющие критериям, выделеныс Условным форматированием с правилом =И($A2=$D$2;$B2>=$E$2;$B2<=$F$2)

Подсчет можно реализовать несколькими разновидностями формул:

  • = СЧЁТЕСЛИМН(A2:A13;D2;B2:B13;">="&E2;B2:B13;"<="&F2)
  • = СУММПРОИЗВ((A2:A13=D2)*(B2:B13>=E2)*(B2:B13<=F2))
  • = СУММ((A2:A13=D2)*(B2:B13<=F2)*(B2:B13>=E2)) формула массива ;
  • = СЧЁТ(ЕСЛИ((A2:A13=D2)*(B2:B13>=E2)*(B2:B13<=F2);B2:B13)) формула массива ;
  • = БСЧЁТА(A1:B13;A1;D14:F15) – в диапазоне D14:F15 содержится табличка с критериями.
  • = БСЧЁТ(A1:B13;B1;D14:F15) с той же табличкой с критериями.

Примечание : подсчет значений с множественными критерями также рассмотрен в статьях Подсчет значений с множественными критериями (Часть 1. Условие И) , Часть2 , Часть3 .

СОВЕТ: Более простой подсчет значений - подсчет значений с единственным критерием приведен в статьях Подсчет текстовых значений с единственным критерием (там же рассмотрен вариант с подстановочными знаками и с учетом РЕгиСТРА) и Подсчет числовых значений с единственным критерием .


Комментарии
Только для авторизованных пользователей

(только для авторизованных пользователей)

© Copyright 2013 - 2020 Excel2.ru. All Rights Reserved