Выбор 2-х случайных значений из списка в EXCEL

Файл примера

Выберем 2 случайных значения из списка значений. Также получим формулу для выбора 1 случайного значения.


Пусть в диапазоне A6:A12 содержится список текстовых значений.

Чтобы выбрать 2 случайных значения из списка (диапазон A6:A12 ) будем действовать следующим образом (см. Файл примера ):

  • сопоставим каждому текстовому значению случайное число (используйте функцию СЛЧИС() ), расположив его в столбце С (см. также статью Сортировка в случайном порядке списка ЧИСЛОвых значений в MS EXCEL );
  • формулы =ИНДЕКС($A$6:$A$12;РАНГ(C6;$C$6:$C$12)) в ячейке D6 и =ИНДЕКС($A$6:$A$12;РАНГ(C7;$C$6:$C$12)) в ячейке D7 вернут 2 случайных текстовых значения из исходного списка.

Функция СЛЧИС() пересчитывает свое значение после каждого ввода нового значения в любую ячейку листа (или изменения значения ячейки) или нажатии клавиши F9 .

Исходный список может содержать совершенно произвольные значения (текст, числа, даты), т.к. функция ИНДЕКС() выводит значение ячейки исходя лишь из его позиции в списке.

Выбор 1 случайного значения из списка

Организовать выбор одного случайного значения из списка - проще чем 2.

Формула =ИНДЕКС(A8:A14;СЛУЧМЕЖДУ(1;СЧЁТЗ(A8:A14))) сначала генерирует случайное целое число от 1 до 7 (номер позиции), где 7 количество значений в списке. Затем по номеру позиции (случайное число) выводится значение из исходного списка.

Файл примера

© Copyright 2013 - 2020 Excel2.ru. All Rights Reserved