Функция СТОЛБЕЦ() в MS EXCEL

Задача функции СТОЛБЕЦ(), английский вариант COLUMN(), - возвращать номер столбца. Формула =СТОЛБЕЦ(B1) вернет 2, т.к. столбец B - второй столбец на листе.

Синтаксис функции СТОЛБЕЦ()

СТОЛБЕЦ(ссылка)

Ссылка - необязательный аргумент. Ячейка или диапазон ячеек, для которого требуется возвратить номер столбца.

В качестве ссылки указан адрес одной ячейки

Если в качестве ссылки указан адрес одной ячейки, то функция вернет номер столбца этой ячейки

=СТОЛБЕЦ(B1) вернет 2, =СТОЛБЕЦ(F2) вернет 6. Чтобы убедиться, что номер столбца F действительно 6 включите стиль ссылок R1C1 (Кнопка Офис/ Параметры Excel/ Формулы/ Работа с формулами/ Стиль ссылок R1C1)

Если требуется задать название столбца через буквенное обозначение, то используйте формулу

=СТОЛБЕЦ(ДВССЫЛ("F"&3))

Аргумент ссылки опущен

Если аргумент ссылки опущен, то предполагается, что это ссылка на ячейку, в которой находится сама функция СТОЛБЕЦ()

Т.е. если формула =СТОЛБЕЦ() введена в ячейку С5, то формула вернет 3.

В качестве ссылки указан диапазон ячеек

Если в качестве ссылки указан диапазон ячеек, и формула введена как обычно (не как формула массива), то функция вернет номер столбца левой верхней ячейки диапазона.

=СТОЛБЕЦ(D26:G26) вернет 4, т.е. номер столбца D.

Если в Строке формул выделить формулу и нажать клавишу F9, то мы увидим, что результатом формулы является не одно значение, а четыре {4;5;6;7} Так как в ячейке можно вывести только одно значение, то выводится, только первое, т.е. 4.

Чтобы вывести все 4 значения (см. статью Формулы массива, возвращающие несколько значений), выделите четыре ячейки, расположенные по горизонтали (A27:D27), в Строке формул введите формулу =СТОЛБЕЦ(D26:G26) и нажмите CTRL+SHIFT+ENTER. см. файл примера.

Формирование массива последовательных чисел

Записав формулу =СТОЛБЕЦ(A26:D26) мы сформируем массив последовательных чисел, который можно использовать в других задачах. Например, найдем сумму числового ряда 1+1/2+1/3+1/4+1/5+1/6+1/7 с помощью формулы =СУММПРОИЗВ(1/СТОЛБЕЦ(A1:G1))

Сумму ряда от 1 до 1/n^2, где n = 7 можно вычислить так: =СУММПРОИЗВ(1/(СТОЛБЕЦ(A1:G1)^2))

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 4 (3 оценок)