Сложение значений в EXCEL в каждой третьей строке

Файл примера

Найдем сумму значений, расположенных в каждой третьей строке, используя функции БДСУММ() и СУММПРОИЗВ() .


Пусть в столбце размещены числовые значения (см. файл примера ). Найдем сумму значений, расположенных в каждой третьей строке.

В файле примера значения, учитываемые при подсчете, выделены с помощью Условного форматирования красным цветом.

Решим задачу двумя способами.

Используем функцию БДСУММ()

Критерий для функции БДСУММ() зададим формулой =ОСТАТ(СТРОКА(A2)-$D$1;$D$1)=0

Заголовок критерия не должен совпадать с заголовками исходной таблицы (базы_данных).

Формула =БДСУММ($A:$A;1;C9:C10) предполагает наличие диапазона с числами в столбце А . Табличка с критериями должна быть размещена в ячейках C9:C10 .

Используем функцию СУММПРОИЗВ()



Решение с функцией СУММПРОИЗВ() компактнее: =СУММПРОИЗВ(--(ОСТАТ(СТРОКА(A1:A100);D1)=0);A1:A100)

Двойное отрицание (--) необходимо для преобразования логических значений ИСТИНА и ЛОЖЬ в 1 и 0 соответственно.

Сложение значений только из четных или нечетных строк

Если значения расположены в диапазоне G2:G135 , то подсчитать сумму из нечетных строк можно с помощью формулы =СУММПРОИЗВ(ОСТАТ(СТРОКА(G2:G135);2);G2:G135)

Соответственно, из четных - по формуле =СУММПРОИЗВ(--НЕ(ОСТАТ(СТРОКА(G2:G135);2));G2:G135)

Также можно создать в таблице дополнительный столбец (пусть это будет столбец J ), определяющий четность строки =ОСТАТ(СТРОКА();2) или =ЕЧЁТН(СТРОКА()) . Формула =СУММЕСЛИ(J2:J135;0;G2:G135) подсчитает сумму в четных строках. В нечетных - =СУММЕСЛИ(J2:J135;1;G2:G135) или можно вычесть из общей суммы сумму в четных строках: =СУММ(G2:G135)-СУММЕСЛИ(J2:J135;0;G2:G135)

Примечание. В статье Сложение каждого второго (третьего и т.п.) значения в списке приведен пример аналогичного сложения, но не относительно строк листа, а относительно позиций в списке (диапазоне ячеек). Там же произведен подробный разбор работы формул.

Файл примера

© Copyright 2013 - 2020 Excel2.ru. All Rights Reserved