Поиск и исправление ошибок в формулах

Функция НД(), английский вариант NA(), возвращает значение ошибки #Н/Д. Значение ошибки #Н/Д означает, что значение недоступно. Рассмотрим случаи, когда эта функция может пригодиться.

Функция ЕОШИБКА(), английский вариант ISERROR(), проверяет на равенство значениям #Н/Д, #ЗНАЧ!, #ССЫЛКА!, #ДЕЛ/0!, #ЧИСЛО!, #ИМЯ? или #ПУСТО! и возвращает в зависимости от этого ИСТИНА или ЛОЖЬ.

Функция ЕНД(), английский вариант ISNA(), проверяет на равенство значению #Н/Д (значение недоступно) и возвращает в зависимости от этого ИСТИНА или ЛОЖЬ.

Функция ЕСЛИОШИБКА(), английский вариант IFERROR(), проверяет выражение на равенство значениям #Н/Д, #ЗНАЧ!, #ССЫЛКА!, #ДЕЛ/0!, #ЧИСЛО!, #ИМЯ? или #ПУСТО! Если проверяемое выражение или значение в ячейке содержит ошибку, то функция возвращает определенное для этого случая значение, в противном случае - результат вычисления выражения или содержимое ячейки.

Функция ЕОШ(), английский вариант ISERR(), проверяет на равенство значениям: #ЗНАЧ!, #ССЫЛКА!, #ДЕЛ/0!, #ЧИСЛО!, #ИМЯ? или #ПУСТО! и возвращает в зависимости от этого ИСТИНА или ЛОЖЬ.

Бывает, что формулы возвращают ошибки (#ДЕЛ/0!, #Н/Д, #ЗНАЧ! и т.д.) Подсчитаем, количество ячеек, содержащих ошибки.

Иногда требуется скрыть в ячейке значения ошибки: #ЗНАЧ!, #ССЫЛКА!, #ДЕЛ/0!, #ЧИСЛО!, #ИМЯ? Сделаем это несколькими способами.

При написании сложных формул, таких как =ЕСЛИ(СРЗНАЧ(A2:A10)>200;СУММ(B2:B10);0), часто необходимо получить промежуточный результат вычисления формулы. Для этого есть специальный инструмент Вычислить формулу.

Если в диапазоне суммирования встречается значение ошибки #Н/Д (значение недоступно), то функция СУММ() также вернет ошибку. Используем функцию СУММЕСЛИ() для обработки таких ситуаций.

Бывает, что введя формулу и нажав клавишу ENTER пользователь видит в ячейке не результат вычисления формулы, а саму формулу. Причина - Текстовый формат ячейки. Покажем как в этом случае заставить формулу работать.