Функция ЕСЛИОШИБКА() в MS EXCEL

Функция ЕСЛИОШИБКА(), английский вариант IFERROR(), проверяет выражение на равенство значениям #Н/Д, #ЗНАЧ!, #ССЫЛКА!, #ДЕЛ/0!, #ЧИСЛО!, #ИМЯ? или #ПУСТО! Если проверяемое выражение или значение в ячейке содержит ошибку, то функция возвращает определенное для этого случая значение, в противном случае - результат вычисления выражения или содержимое ячейки.

Функция ЕСЛИОШИБКА() впервые появилась в EXCEL 2007.

Синтаксис функции

ЕСЛИОШИБКА(значение;значение_при_ошибке)

Значение - аргумент, проверяемый на возникновение ошибок.

Значение_при_ошибке   — значение, возвращаемое при ошибке.

Для обработки ошибок #Н/Д, #ЗНАЧ!, #ССЫЛКА!, #ДЕЛ/0!, #ЧИСЛО!, #ИМЯ? или #ПУСТО! обычно используют формулу вида (см. файл примера):
=ЕСЛИОШИБКА(A2/B2;"Ошибка расчете")

Формула проверяет на предмет ошибки результат вычисления A2/B2.

Если результат вычисления не является ошибкой #Н/Д, #ЗНАЧ!, #ССЫЛКА!, #ДЕЛ/0!, #ЧИСЛО!, #ИМЯ? или #ПУСТО! , то формула возвращает результат вычисления A2/B2, если обнаруживает, то возвращает строку Ошибка в расчете.

Функция ЕСЛИОШИБКА() vs ЕОШИБКА()

В отличие от функции ЕСЛИОШИБКА() функция ЕОШИБКА() не умеет самостоятельно обрабатывать ошибку - приходится задействовать функцию ЕСЛИ():
=ЕСЛИ(ЕОШИБКА(A2/B2);"Ошибка в расчетах";A2/B2)

Т.к. функция ЕСЛИОШИБКА() впервые появилась в EXCEL 2007, то в более ранних версиях придется использовать функцию ЕОШИБКА().

Обратите внимание, что использована именно ЕОШИБКА(), а не ЕОШ(), т.к. для последней ошибка #Н/Д ошибкой не является (см. рисунок выше).

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 3.8 (9 оценок)
Яндекс.Метрика