Функция НД() в MS EXCEL

Функция НД(), английский вариант NA(), возвращает значение ошибки #Н/Д. Значение ошибки #Н/Д означает, что значение недоступно. Рассмотрим случаи, когда эта функция может пригодиться.

Синтаксис функции

НД()

Функцию НД() использовать можно следующим образом:

=ЕСЛИ(A3<0;НД();A3)

Т.е. если значение в ячейке А3 меньше 0, то формула возвращает ошибку #Н/Д. В каких случаях лучше вернуть значение ошибки #Н/Д, чем другие значения, например ЛОЖЬ или 0 или, например, текстовую строку "меньше 0" или числовое значение - решает пользователь, но когда это действительно удобно?

Преимущество значения #Н/Д заключается при построении диаграмм, т.е. это значение игнорируется (см. статью Основные типы диаграмм в MS EXCEL раздел График).

Построим 3 графика, каждый будет состоять из 5 значений (см. файл примера).

Значение #Н/Д при построении графика пропускается (синий график). Обратите внимание, что зеленый график (для пустой ячейки) на второй диаграмме ведет аналогично. Это достигнуто с помощью настроек диаграммы (вкладка Конструктор, группа Данные, нажмите Выбрать данные, в появившемся окне нажмите кнопку Скрытые и пустые ячейки, выберите Показывать линию).

Однако, как правило, вместо пустой ячейки в таблицах используют значение пустой текст "", которое не отображается в ячейке, но является текстовой строкой. На диаграмме текстовые значения заменяются 0. Именно, в этом случае пригодится функция НД().

Вместо формулы =ЕСЛИ(A3<0;"";A3) следует использовать формулу =ЕСЛИ(A3<0;НД();A3) - лишние 0 на графике отображаться не будут.

Другим примером использования значения #НД является статья Динамические диаграммы. Часть3: Выделение данных на диаграмме цветом.

Также значение #НД помогает скрыть один из графиков, не нужный в данный момент.

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 5 (1 оценка)
Яндекс.Метрика