Функция ЕОШ() в MS EXCEL

Функция ЕОШ(), английский вариант ISERR(), проверяет на равенство значениям: #ЗНАЧ!, #ССЫЛКА!, #ДЕЛ/0!, #ЧИСЛО!, #ИМЯ? или #ПУСТО! и возвращает в зависимости от этого ИСТИНА или ЛОЖЬ.

Синтаксис функции

ЕОШ(значение)

Значение - ссылка на ячейку или результат вычисления выражения, которое необходимо проверить.

Функция ЕОШ() vs ЕОШИБКА() и ЕСЛИОШИБКА()

В отличие от функций ЕОШИБКА() и ЕСЛИОШИБКА() функция ЕОШ() считает, что значение ошибки #Н/Д не является ошибкой.

Для обработки ошибок #ЗНАЧ!, #ССЫЛКА!, #ДЕЛ/0!, #ЧИСЛО!, #ИМЯ? или #ПУСТО! используют формулы следующего вида (см. файл примера):
=ЕСЛИ(ЕОШ(A1);"ОШИБКА!";A1) или =ЕСЛИ(ЕОШ(A1/A2);"ОШИБКА!";A1/A2)

В случае наличия в ячейке А1 ошибки, формулой выводится слово ОШИБКА!

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 4.5 (4 оценок)
Яндекс.Метрика