Функция ЕОШИБКА() в MS EXCEL

Функция ЕОШИБКА(), английский вариант ISERROR(), проверяет на равенство значениям #Н/Д, #ЗНАЧ!, #ССЫЛКА!, #ДЕЛ/0!, #ЧИСЛО!, #ИМЯ? или #ПУСТО! и возвращает в зависимости от этого ИСТИНА или ЛОЖЬ.

Синтаксис функции

ЕОШИБКА(значение)

Значение - ссылка на ячейку или результат вычисления выражения, которое необходимо проверить.

Функция ЕОШИБКА() vs ЕОШ()

Функции ЕОШИБКА() в отличие от функции ЕОШ() считает, что значение #Н/Д является ошибкой. Т.е. =ЕОШИБКА(НД()) вернет ИСТИНА, а =ЕОШ(НД()) вернет ЛОЖЬ.

Для обработки ошибок #Н/Д, #ЗНАЧ!, #ССЫЛКА!, #ДЕЛ/0!, #ЧИСЛО!, #ИМЯ? или #ПУСТО! используют формулы следующего вида:
=ЕСЛИ(ЕОШИБКА(A1);"ОШИБКА!";A1) или =ЕСЛИ(ЕОШИБКА(A1/A2);"ОШИБКА!";A1/A2)

В случае наличия в ячейке А1 ошибки или ошибки при вычислении выражения A1/A2, формулой выводится слово ОШИБКА! В противном случае - содержимое ячейки A1 или, соответственно, результат вычисления выражения A1/A2.

Функция ЕОШИБКА() vs ЕСЛИОШИБКА()

Функция ЕСЛИОШИБКА() впервые появилась в EXCEL 2007 и упростила написание формул для обработки ошибок. Если раньше приходилось писать формулы на подобие этой =ЕСЛИ(ЕОШИБКА(A1);"ОШИБКА!";A1), то теперь достаточно записать =ЕСЛИОШИБКА(A1;"ОШИБКА!"): в случае наличия в ячейке A1 ошибки будет выведено значение ОШИБКА!, в противном случае - содержимое ячейки A1.

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 3.6 (5 оценок)