Настройка формул

В формулах EXCEL можно сослаться на другую ячейку используя ее адрес. Адрес ячейки в формуле можно записать по-разному, например: А1 или $A1 или $A$1. То, каким образом вы введете адрес в формулу, будет зависеть, как он будет модифицироваться при ее копировании в другие ячейки листа. Понимание типов ссылок крайне важно как при построении обычных формул на листе, так и при создании Именованных формул, задания правил Условного форматирования и при формировании условий Проверки данных.

Обычно формулы непосредственно вводятся в ячейки, но можно, предварительно присвоив формуле имя, использовать в ячейке ее имя. Какие преимущества дает именованная формула – читайте в этой статье.

Применим средства EXCEL для поиска и выделения ячеек, содержащих и НЕ содержащих формулы.

При написании сложных формул, таких как =ЕСЛИ(СРЗНАЧ(A2:A10)>200;СУММ(B2:B10);0), часто необходимо получить промежуточный результат вычисления формулы. Для этого есть специальный инструмент Вычислить формулу.

Строка формул - это панель в верхней части окна Microsoft Excel, которая используется для ввода и изменения значений или формул в ячейках листа. В Строке формул отображается значение или формула, содержащаяся в активной ячейке.

Используем Поле Имя (находится слева от Строки формул) для быстрого ввода функций из списка последних 10 использовавшихся.

Бывает, что введя формулу и нажав клавишу ENTER пользователь видит в ячейке не результат вычисления формулы, а саму формулу. Причина - Текстовый формат ячейки. Покажем как в этом случае заставить формулу работать.

Если в ячейке G1 имеется формула для суммирования значений в столбце D (=СУММ(D2:D10)), то при вставке нового столбца между А и D формула будет автоматически изменена на =СУММ(E2:E10), что безусловно правильно и удобно. Однако, иногда требуется иметь формулу, которая всегда ссылается на один и тот же столбец вне зависимости от модификаций листа, например, при вставке значений в четвертый столбец (т.е. D) программой VBA (макросом).

На листе с множеством формул часто бывает трудно ориентироваться. Например, чтобы удалить ненужные формулы нужно их сначала найти. Для поиска формул на листе в EXCEL есть ряд интересных инструментов.

При составлении сложных формул бывает полезно быстро узнать промежуточный результат вычисления, выполненный частью формулы.

Если в ячейке содержится длинная формула, то с помощью символа Разрыв строки (ALT+ENTER) удобно отобразить ее в нескольких строчках в поле Строка формул.  

Чтобы не подвергать пользователя искушению изменять формулы, можно их скрыть.