Функция ЕНД() в MS EXCEL

Функция ЕНД(), английский вариант ISNA(), проверяет на равенство значению #Н/Д (значение недоступно) и возвращает в зависимости от этого ИСТИНА или ЛОЖЬ.

Синтаксис функции

ЕНД(значение)

Значение - ссылка на ячейку или результат вычисления выражения, которое необходимо проверить.

Функция ЕНД() позволяет обработать ошибку #Н/Д. Откуда берется эта ошибка? Некоторые функции, например ПРОСМОТР()ПОИСКПОЗ() или ВПР() могут вернуть ошибку #Н/Д (значение недоступно). Значение ошибки #Н/Д не очень информативно, поэтому вместо значения #Н/Д можно обработать, т.е., например, заменить #Н/Д на слово "Ошибка" или другое информационное сообщение типа "Значение не найдено" или "Введите другое число".

Например, если в ячейке Е2 содержится ошибка #Н/Д, то в любой другой пустой ячейке можно ввести формулу =ЕСЛИ(ЕНД(E2);"ОШИБКА!";E2)

Теперь если в ячейке Е2 содержится ошибка #Н/Д, то будет выведено слово ОШИБКА! (см. файл примера).

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 5 (1 оценка)

Комментарии

Mark (не проверено)

Не понятно

Creator

Советую посмотреть файл примера и справку по функции ВПР() (см. внизу статьи вкладку Использованные функции или вот прямая ссылка http://excel2.ru/funkcii/end)

Serafim

В вашем файле с примером какая-то особенная формула)
Сама формула: =ЕСЛИ(ЕНД(ВПР(D5;A5:B9;2;ЛОЖЬ));"ОШИБКА!";
В ячейке с формулой (E6) в конце стоит точка с запятой и нет скобки-закрытия формулы (при попытках её добавить, после нажатия Enter выдаёт "Ошибка в формуле").
Мой пример: ;"ОШИБКА!") и ;"ОШИБКА!";)
Формула в вашем примере работает абсолютно правильно, но попытки её повторить тщетны :-\
Суть проблемы:
Формула легко убирает значение #Н/Д и ставит вместо него любое другое, как в вашем примере "ОШИБКА!". В случае если значение не #Н/Д, то формула ставит значение "ЛОЖЬ", а если в конце поставить точку с запятой, то значение становиться "0".

Creator

Формула в Строке формул располагается на 2-х строках.

=ЕСЛИ(ЕНД(ВПР(D5;A5:B9;2;ЛОЖЬ));"ОШИБКА!";
ВПР(D5;A5:B9;2;ЛОЖЬ))

Прочитайте статью Строка формул в MS EXCEL и отобразите формулу полностью.