Строка формул в MS EXCEL

Строка формул - это панель в верхней части окна Microsoft Excel, которая используется для ввода и изменения значений или формул в ячейках листа. В Строке формул отображается значение или формула, содержащаяся в активной ячейке.

Строка формул находится в верхней части окна Excel.

Изменение высоты Строки формул

Для упрощения просмотра и редактирования большого объема текста в ячейке или длинной формулы можно настроить высоту Строки формул.

Нажав сочетание клавиш CTRL+SHIFT+U, высота Строки формул увеличится, что позволит одновременно отображать несколько строк.

Развернуть Строку формул также можно нажав кнопку, расположенную в правом краю Строки формул (на рисунке выше кнопка "с шевроном" выделена красным кружком.)

Повторное нажатие сочетания клавиш CTRL+SHIFT+U или кнопки "с шевроном" свернет Строку формул.

Для точной настройки высоты Строки формул установите курсор мыши на нижний край Строки формул так, чтобы он принял вид вертикальной двусторонней стрелки.

Нажав левую клавишу мыши, перетащите край Строки формул вниз на необходимое количество строк, а затем отпустите клавишу мыши.

Установленная таким образом высота Строки формул будет запомнена EXCEL и в дальнейшем будет использована при разворачивании Строки формул с помощью сочетания клавиш CTRL+SHIFT+U или кнопки "с шевроном".

Высоту Строки формул можно увеличить практически на весь лист, но хотя бы одна строка будет отображаться на листе полностью (эта строка будет содержать активную ячейку).

Для автоматического подбора высоты Строки формул, достаточного для полного отображения содержимого активной ячейки, установите курсор мыши на нижний край Строки формул так, чтобы он принял вид вертикальной двусторонней стрелки, а затем дважды кликните левой клавишей мыши.

Чтобы свернуть Строку формул обратно нажмите сочетание клавиш CTRL+SHIFT+U или кнопку "с шевроном".

Просмотр промежуточного результата вычисления формулы

В Строке формул можно быстро посмотреть промежуточный результат вычисления сложной формулы.

Выделим в Строке формул интересующую часть формулы и нажмем клавишу F9, в Строке формул будет отображен результат вычисления.

Нажатие клавиши ESC вернет просматриваемую часть формулы в прежнее состояние, нажатие клавиши ENTER заменит часть формулы результатом ее вычисления.

Подробности можно прочитать в статье Просмотр промежуточного результата вычисления формулы (клавиша F9).

Отображение длинных формул

Пусть в ячейке имеется длинная формула:
=+ЕСЛИ($A2=0;0; ЕСЛИ ($B2<4264;0;ЕСЛИ (И($B2>=4264;$B2<=4895);(-22,31*$C2/365);ЕСЛИ (И($B2>=4895;$B2<=32760);($B2*0,093-476,89)*$C2/365;ЕСЛИ ($B2>32760;($B2*0,128-1623,49)*$C2/365)))))

В Строке формул такую громоздкую формулу можно отобразить полностью (см. выше), но ее трудно воспринимать. Гораздо удобнее работать с формулой в таком виде:
=+ЕСЛИ($A2=0;0;
ЕСЛИ($B2<4264;0;
ЕСЛИ(И($B2>=4264;$B2<=4895);(-22,31*$C2/365);
ЕСЛИ(И($B2>=4895;$B2<=32760);($B2*0,093-476,89)*$C2/365;
ЕСЛИ($B2>32760;($B2*0,128-1623,49)*$C2/365)))))

Привести формулу в Строке формул к такому виду можно вставив перед функциями ЕСЛИ() символ Разрыв строки (символ Разрыв строки не влияет на вычисления). Символ Разрыв строки можно вставить, нажимая комбинацию клавиш ALT+ENTER.

Подробности можно прочитать в статье Вставка символа Разрыва строки для удобства чтения формул в ячейке.

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 4 (6 оценок)
Яндекс.Метрика