Просмотр в MS EXCEL промежуточного результата вычисления формулы (клавиша F9)

При составлении сложных формул бывает полезно быстро узнать промежуточный результат вычисления, выполненный частью формулы.

Рассмотрим формулу =(A1+B1)*A2/B2. Пусть нам потребовалось быстро узнать результат вычисления A2/B2. Чтобы не терять зря времени на создание новых формул в соседних ячейках, делаем следующее:

  • выделяем ячейку с формулой;
  • в Строке формул мышкой выделяем A2/B2 (тем самым входим в Режим Правки ячейки);
  • нажимаем клавишу F9;
  • EXCEL заменяет A2/B2 на результат.

Если после отображения результата Вы нажмете клавишу ECS, то EXCEL вернет формулу обратно, если ENTER, то заменит выделенную часть формулы результатом. Особенно начинаешь ценить этот прием при работе с формулами массива.

Рассмотрим другой пример с формулой массива =СУММ((Продажи>=6)*(Продажи<=10)*(Продажи)) Пусть формула введена в ячейку B2, а диапазону A2:A13, содержащему некие суммы Продаж, присвоено имя Продажи.В формуле вместо ссылки на обычный диапазон использована ссылка на  Именованный диапазон Продажи. Как видно из формулы, она складывает только те значения из исходного списка значений, которые больше или равны шести и меньше или равны 10.

Проверим, какие значения из исходного диапазона были выбраны для суммирования.

  • Выделим ячейку с формулой (B2);
  • Выделим в Строке формул выражение (Продажи>=6)*(Продажи<=10)*(Продажи);
  • Нажмем F9;
  • Получим массив {0:0:0:0:0:6:7:8:9:10:0:0}

Действительно, все ненулевые значения лежат в интервале [6;10]

Другим вариантом является использование инструмента Вычислить формулу (Формулы/ Зависимости формул/ Вычислить формулу).

Примечание:
Нажатие клавиши F9 имеет разный эффект при различных режимах выделения ячейки. Если ячейка просто выделена (в левом нижнем углу окна EXCEL выведена надпись Готово),

то нажатие клавиши F9 приведет к пересчету формул на листе (Формулы/ Вычисления/ Пересчет).

Если ячейка находится в Режиме Правка (в левом нижнем углу окна EXCEL выведена надпись Правка),

то нажатие клавиши F9 приведет к замене выделенного фрагмента формулы на ее значение. В Режим Правка можно войти дважды кликнув на значение в ячейке или поставив курсор в Строку формул или нажав клавишу F2.

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 5 (3 оценок)