Скрываем один из графиков на диаграмме в MS EXCEL

Построим на диаграмме 2 графика. С помощью элемента управления Флажок скроем один из графиков.

Иногда требуется на одной диаграмме построить два графика, причем один из них должен отключаться при необходимости.

Исходные данные для диаграммы представлены в таблице (см. файл примера). Например, для графика 1 данные представляют собой значения плотности нормального распределения, вычисляемой по формуле =НОРМРАСП(E5;B$5;B$7;ЛОЖЬ). Конечно, можно использовать любые другие данные.

Построим 2 графика. Для этого выделим 2 столбца с данными (График1 и График2) и выберем тип диаграммы График (Вставка/ Диаграммы/ График/График).

Создадим элемент управления формы Флажок и свяжем его с ячейкой B10. С помощью него будем отключать/ включать отображение графика 2.

В исходной таблице в столбце График2 изменим формулу на =ЕСЛИ($B$10;НОРМРАСП(E5;B$5;B$7;ЛОЖЬ);НД())

Теперь при установленном флажке график будет отображаться, а при снятом - нет.

В принципе для скрытия графика 2 можно скрыть соответствующий столбец с данными G, см. аналогичный пример для строк в статье Динамические диаграммы. Часть1: Выборка данных через скрытие строк.

СОВЕТ: Для начинающих пользователей EXCEL советуем прочитать статью Основы построения диаграмм в MS EXCEL, в которой рассказывается о базовых настройках диаграмм, а также статью об основных типах диаграмм.

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 4.3 (3 оценок)