Подсчет ЧИСЕЛ которые имеют повторы в EXCEL

Произведем подсчет ЧИСЛОвых значений, которые имеют повторы.


Исходный список содержит: { 5 , 5, 5, 6 , 6, 3}. Количество чисел, которые имеют повторы, равно 2. Это числа 5 и 6.

Если исходный список значений находится в диапазоне А7:А15 , то количество чисел, имеющих повторы, можно вычислить с помощью формулы =СУММПРОИЗВ(--(ЧАСТОТА(A7:A15;A7:A15)>1))

Формула подсчитывает только числовые значения. Текстовые значения игнорируются, диапазон может содержать пустые ячейки.

Примечание . В отличие от статьи Подсчет повторяющихся значений (дубликатов) , где подсчитывались все дубликаты, здесь подсчитываются только первые дубликаты (или другими словами: все повторяющиеся за исключением их повторов, или другой вариант: все уникальные за исключением неповторяющихся). Чтобы не запутаться в этом зоопарке терминов, можно обратиться к статье Классификация значений по уникальности .

СОВЕТ: Для подсчета текстовых значений, которые имеют повторы, необходимо из количества уникальных значений (статья Подсчет уникальных текстовых значений ) вычесть количество неповторяющихся (статья Подсчет неповторяющихся значений ).


© Copyright 2013 - 2020 Excel2.ru. All Rights Reserved