Подсчет Неповторяющихся значений в EXCEL

Произведем подсчет неповторяющихся значений в списке, содержащем повторы. Диапазон может содержать текстовые значения и числа.


Если исходный список значений находится в диапазоне А7:А16 (см. файл примера ), то число неповторяющихся значений можно вычислить с помощью формулы =СУММПРОИЗВ(--(СЧЁТЕСЛИ(A7:A16;A7:A16)=1))

Формула хороша тем, что производит подсчет и текстовых и числовых значений, кроме того, она игнорирует пустые ячейки.

Неповторяющиеся значения на рисунке выделены с помощью Условного форматирования (см. статью Выделение неповторяющихся значений в MS EXCEL ).

СОВЕТ: Решение обратной задачи (подсчет повторяющихся значений) можно найти в статье Подсчет повторяющихся значений (дубликатов) . Вообще, если от общего количества значений отнять число неповторяющихся, то получим количество повторяющихся значений.


© Copyright 2013 - 2020 Excel2.ru. All Rights Reserved