Подсчет повторяющихся значений (Дубликатов) в EXCEL

Произведем подсчет всех повторяющихся значений в списке, содержащем повторы. Диапазон может содержать текстовые значения и числа.


Если исходный список содержит: { 1 , 1 , 2 , 3, 1 , 2 }. Тогда количество значений, которые повторяются будет равно 5, т.е. {1, 1, 2, 1, 2} (значения в исходном массиве выделены жирным ).

Если исходный список значений находится в диапазоне А7:А16 (см. файл примера ), то число повторяющихся значений можно вычислить с помощью формулы =СУММПРОИЗВ(--(СЧЁТЕСЛИ(A7:A16;A7:A16)>1))

Формула хороша тем, что производит подсчет и текстовых и числовых значений, кроме того, она игнорирует пустые ячейки.

Повторяющиеся значения на рисунке выделены с помощью Условного форматирования (см. статью Выделение повторяющихся значений в MS EXCEL ).

СОВЕТ: Решение обратной задачи по подсчету неповторяющихся значений можно найти здесь: Подсчет неповторяющихся значений . Вообще, если от общего количества значений отнять число повторяющихся, то получим количество неповторяющихся значений.


Комментарии
Только для авторизованных пользователей

Аноним, 6 марта 2016 г.
На заметку
Аноним, 2 ноября 2018 г.
спасибо!
(только для авторизованных пользователей)

© Copyright 2013 - 2020 Excel2.ru. All Rights Reserved