Динамические диаграммы в MS EXCEL. Часть2: Выборка данных формулами

Часто на диаграмме необходимо отобразить не все значения из исходной таблицы, а только те, которые удовлетворяют определенным критериям. Для построения такой диаграммы можно использовать формулы. В этом случае необходимо предварительно создать отдельную таблицу для данных, удовлетворяющих заданным условиям.

Пусть имеется таблица поставок фруктов разными поставщиками (см. файл примера):

Построим диаграмму суммарных поставок определенного фрукта по каждому поставщику.

Выборку данных из исходной таблицы будем осуществлять функцией СУММПРОИЗВ(): =СУММПРОИЗВ($D$3:$D$100*($B$3:$B$100=G3)*($C$3:$C$100=$H$1))

Фрукт, поставки которого нужно отобразить, можно, например, выбирать из Выпадающего (раскрывающегося) списка (ячейка H1), реализованного на основе инструмента Проверка данных.

В принципе, аналогичного результата можно добиться функцией СУММЕСЛИМН(), формулами массива или другими функциями (см., например статью Сложение с несколькими критериями (Часть 1. Введение)).

С другими динамическими диаграммами можно познакомиться в статье Динамические диаграммы. Общие замечания.

СОВЕТ: Для начинающих пользователей EXCEL советуем прочитать статью Основы построения диаграмм в MS EXCEL, в которой рассказывается о базовых настройках диаграмм, а также статью об основных типах диаграмм.

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 5 (1 оценка)