Выборочно скрываем подписи данных на диаграмме в MS EXCEL

Подписи данных на диаграмме часто необходимы, но могут ее загромождать. Отобразим только те подписи данных (значения), которые больше определенного порогового значения.

Построим диаграмму MS EXCEL в форме гистограммы, отобразим подписи данных (см. файл примера).

Предположим, что нас интересуют только значения выше 350. Те, что ниже - можно не отображать.

Добиться такого результата можно несколькими приемами, в этой статье приведем 2.

Скрытие значений <=350 через Формат

Самым быстрым способом добиться результата - использовать пользовательский формат подписей данных.

Для этого выделите подписи данных и правой клавишей мыши вызовите окно Формат подписей данных..., перейдите во вкладку Число.

В поле Код формата введите [>350]# ##0;  (после точки запятой введите пробел).

Нажмите Добавить.

Здесь мы применили условный формат (значения >350 выводятся в числовом формате, остальные значения заменяются пробелом).

При частой смене порогового значения этот прием не очень удобен, т.к. приходится вручную изменять формат.

Скрытие значений <=350 через Дополнительный ряд

Если пороговое значение часто изменятся, то его имеет смысл вводить в отдельную ячейку (Е25).

Создадим в столбце B дополнительный ряд с помощью функции =ЕСЛИ(A25>$E$25;A25;)

Если значение выше порогового значения, то формула выводит его, если нет, то возвращается 0. Добавим в диаграмму этот ряд и установим перекрытие рядов без зазора.

Необходимо изменить цвет гистограммы дополнительного ряда с зеленого на синий, а формат подписей данных изменить на # ##0;# ##0; (чтобы не отображались нулевые значения).

В итоге получим требуемый результат, причем при изменении порогового значения в ячейке Е25 диаграмма будет динамически перестраиваться.

На рисунке ниже пороговое значение установлено =250.

СОВЕТ: Для начинающих пользователей EXCEL советуем прочитать статью Основы построения диаграмм в MS EXCEL, в которой рассказывается о базовых настройках диаграмм, а также статью об основных типах диаграмм.

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 5 (3 оценок)