Поиск ЧИСЛОвых значений и вывод соответствующих значений в отдельный список в EXCEL

history

Найдем числовые значения, равные заданному пользователем критерию. Поиск будем осуществлять в диапазоне с повторяющимися значениями. При наличии повторов, можно ожидать, что критерию будет соответствовать несколько значений. Для их вывода в отдельный диапазон удобно использовать формулы массива.


Пусть имеется перечень учеников класса. Каждому ученику в случайном порядке достался вариант контрольной работы (от 1 до 5) (см. файл примера ), диапазон A7:B25 .

Задача

Необходимо в отдельном столбце вывести фамилии тех учеников, кому достался, например, вариант 5.

Решение



Для удобства написания формул создадим именованные диапазоны Вариант ( A7:A25 ) и Ученик ( B 7: B 25) .

По аналогии с решением из статьи Поиск текстовых значений в списках. Часть1. Обычный поиск напишем формулу массива для вывода интересующих нас значений:

=ЕСЛИОШИБКА(ИНДЕКС(Ученик; НАИМЕНЬШИЙ(ЕСЛИ(D7=Вариант;СТРОКА(Вариант)-СТРОКА($A$6);9999); СТРОКА(ДВССЫЛ("A1:A"&ЧСТРОК(Вариант)))));"")

С помощью Выпадающего списка в ячейке D7 пользователь может выбрать вариант от 1 до 5. Соответствующие фамилии учеников будут выведены в столбце F .

© Copyright 2013 - 2022 Excel2.ru. All Rights Reserved