Функция ЕСЛИ в EXCEL

Функция ЕСЛИ() , английский вариант IF(), используется при проверке условий. Например, =ЕСЛИ(A1>100;"Бюджет проекта превышен";"ОК!"). В зависимости от значения в ячейке А1 результат формулы будет либо "Бюджет превышен" либо "ОК!".


Функция ЕСЛИ() относится к наиболее часто используемым функциям. Поэтому рассмотрим ее подробно.

Синтаксис функции

ЕСЛИ(лог_выражение;значение_если_истина;[значение_если_ложь])

Функция имеет 3 аргумента.

Лог_выражение — любое значение или выражение, принимающее значения ИСТИНА или ЛОЖЬ. Например, выражение A1>100. Если в ячейке А1 содержится значение 102, то выражение A1>100 вернет ИСТИНА, т.к. 102>100. Если в ячейке А1 содержится значение 88, то выражение вернет ЛОЖЬ, т.к. неравенство 88>100 неверно. Полностью формула может выглядеть так =ЕСЛИ(A1>100;"Бюджет проекта превышен";"ОК!") Если в ячейке A1 содержится значение большее 100, то формула вернет текстовое значение Бюджет проекта превышен, а если меньше 100 или равное 100, то будет выведено ОК!

Других значений кроме ИСТИНА или ЛОЖЬ логическое выражение вернуть не может. Любое число кроме 0 в первом аргументе будет преобразовано в ИСТИНА, ноль - в ЛОЖЬ. Если ошибочно будет указано текстовое значение, то функция вернет ошибку #ЗНАЧ!.

Примечание : Ошибка #ЗНАЧ! может быть также из-за ошибок в выражениях указанных во втором и третье аргументе.

Второй аргумент - Значение_если_истина и третий аргумент значение_если_ложь

Как было показано выше, если логическое выражение (первый аргумент функции) принимает значение ИСТИНА, то функция возвращает значение из второго аргумента значение_если_истина. Соответственно, если логическое выражение принимает значение ЛОЖЬ, то функция возвращает значение из третьего аргумента значение_если_ложь .

Второй и третий аргумент могут быть любым значением (число или текст) или являться выражением (формулой с функциями). Например формула =ЕСЛИ(A1>100;0;А1*1%) позволяет вычислять премию для проектов, в которых не было превышения бюджета (>100). Если бюджет превышен (в А1 введено значение 200 или любое другое более 100), то формула вернет 0, если в А1 введено значение менее 100, то будет вычислено значение премии А1*1% (т.е. если в А1 число 90, то формула вернет 0,9).

Если в качестве второго и третьего аргументов введено выражение, то оно может содержать и функции, например: =ЕСЛИ(A1>100;СУММ(B1:B10);СУММ(C1:C10)) Т.е. если в ячейке A1 содержится значение >100, то суммирование ведется по столбцу B , а если меньше или равно 100, то по столбцу С . Не забывайте, что при значении А1 = 100 в данном случае будет срабатывать выражение из аргумента значение_если_ложь.

Аргумент значение_если_ложь можно опустить (не вводить), тогда при значении логического выражения =ЛОЖЬ будет выведено ЛОЖЬ. Например, если в А1 содержится 600, то формула =ЕСЛИ(A1>=1000;"Больше или равно 1000") вернет просто ЛОЖЬ. Понятно, что при значении логического выражения =ИСТИНА будет выведено "Больше или равно 1000", т.е. второй аргумент функции ЕСЛИ() - Значение_если_истина.

Вложенные ЕСЛИ



Для построения более сложных проверок в одной формуле можно использовать несколько функций ЕСЛИ(). Для этого в качестве значений аргументов значение_если_истина и значение_если_ложь введите еще одно условие с функцией ЕСЛИ(). Например, для проверки в какой диапазон попадает значение из ячейки А8 запишите формулу

=ЕСЛИ(A8<5;1;ЕСЛИ(A8>10;3;2))

  • Если значение из ячейки А8 менее 5, то будет выведено 1
  • Если значение из ячейки А8 более 10, то будет выведено 3
  • Если значение из ячейки А8 между 5 и 10 (включая 5 и 8), то будет выведено 2

Примечание : В версии EXCEL 2007 можно использовать до 64 вложенных друг в друга функций ЕСЛИ(). Но, пожалуйста, не делайте так. Такой подход чреват ошибками.

Примечание : Формулу =ЕСЛИ(A8<5;1;ЕСЛИ(A8>10;3;2)) можно переписать как =ЕСЛИ(A8>=5;ЕСЛИ(A8>10;3;2);1) или ЕСЛИ(A8>=5;ЕСЛИ(A8>10;3;2);1)

или более сложный вариант =ЕСЛИ(A8<5;1;ЕСЛИ(И(5 < A8;A8<10);2;3)). Последний вариант позволяет последовательно перебирать диапазоны изменения А8, но требует знания работы логических функций.

Формула =ЕСЛИ(A8<5;1;ЕСЛИ(A8>10;3;2)) работает следующим образом: сначала вычисляется логическое выражение A8<5. Если оно истинно, то выводится 1, вычисления завершены. Если оно ложно, т.е. А8>=5, то EXCEL переходит к вычислению выражения ЕСЛИ(A8>10;3;2). Опять сначала вычисляется логическое выражение A8>10. Если оно истинно, то выводится 3, вычисления завершены. Если оно ложно, то выводится 2, вычисления завершены.

Чтобы грамотно написать формулу с вложенными ЕСЛИ() следуйте следующим простым правилам:

1) Определитесь с диапазонами:

1.1) они не должны пересекаться. В примере выше - 3 диапазона и значение из А8 гарантированно попадет только в один из них. Было бы ошибкой написать формулу типа =ЕСЛИ(A8<5;1;ЕСЛИ(A8>10;3;ЕСЛИ(A8<3;2;4))). Области значений у выражений A8<5 и A8<3 пересекаются и крайне сложно безошибочно прописывать такие условия. Такая формула просто не верна. Очевидно, что в этом случае 4 диапазона: меньше 3; от 3 до 5; от 5 до 10 и больше 10. Как прописать такие условия написано ниже в этом разделе.

1.2.) диапазоны должны полностью охватывать нужную область значений. Очевидно, что в формуле =ЕСЛИ(A8<5;1;ЕСЛИ(A8>10;3;2)) на интересует вся числовая ось от минус бесконечности до +бесконечности. И все 3 диапазона полностью покрывают эту область.

1.3.) Не забудьте ставить знак равно, чтобы при значениях А8 совпадающих с границами интервалов не было неправильных вычислений. Например, если в формуле =ЕСЛИ(A8>=5;ЕСЛИ(A8>10;3;2);1) забыть указать знак = в логическом выражении A8>=5, то при А8=5 формула =ЕСЛИ(A8>5;ЕСЛИ(A8>10;3;2);1) вернет 1, тогда как исходная формула вернет 2.

Примечание: В перечисленных выше случаях логические выражения вычисляются на основании одной переменной А8. Иногда нужно придумывать формулы с ЕСЛИ(), зависящие от 2-х и более ячеек: =ЕСЛИ(B8>=5;ЕСЛИ(A8>10;3;2);1). Это гораздо сложнее, но, конечно, возможно. Следуйте правилам 1.1)-1.3) и следите за диапазонами. Еще сложнее, если обе переменных являются зависимыми, т.е. например B8 вычисляется на основании А8. Написание таких формул требует предельной аккуратности и напрямую связано с корректностью формулирования самой задачи (возможно вы не продумали до конца как использовать такую сложную зависимость). Советую по возможности разбить вычисления на 2 или более формулы, чтобы проще контролировать результат вычисления.

2) Правильно записывайте логические выражения. Например, условие 5 < A8<10 в EXCEL не будет работать. В этом выражении фактически записано 2 условия. Нужно записать эти 2 условия по отдельности. Чтобы их объединить нужна функция И(): И(5 < A8;A8<10) Подробности в этой статье https://excel2.ru/articles/funkciya-i-v-ms-excel-i или потребуется переделать формулу с вложенными ЕСЛИ().

3) Используйте для наглядности построчное написание вложенных ЕСЛИ. Например, формулу =ЕСЛИ(A8<5;1;ЕСЛИ(A8>10;3;2)) в строке формул можно записать как

=ЕСЛИ(A8<5;1;
ЕСЛИ(A8>10;3;2))

Для этого поставьте курсор перед вторым ЕСЛИ(), нажмите и удерживайте клавишу ALT, нажмите ENTER.

4) для отладки вложенных ЕСЛИ вместо реальных вычислений (V8*10%-37500) используйте простые значения - последовательности 1; 2; 3 ... Это покажет какой блок вложенных ЕСЛИ() срабатывает.

5) В ряде случаев от вложенных ЕСЛИ можно отказаться. Рассмотрим пример определения размера проекта от его бюджета

=ЕСЛИ(A1>=100;"Очень крупный проект";
ЕСЛИ(A1>=90;"Крупный проект";
ЕСЛИ(A1>=50;"Средний проект";"Малый проект ")))

Вышеуказанную формулу можно усложнять и дальше, но есть другие подходы. Ниже приведено 2 эквивалентные формулы:

=ПРОСМОТР(A1;{0;50;90;100};{"Малый проект";"Средний проект";"Крупный проект";"Очень крупный проект"})

=ВПР(A1;A3:B6;2)

Для функции ВПР() необходимо создать в диапазоне A3:B6 таблицу значений:

Формула =ПРОСМОТР(A1;{0;50;90;100};{"Малый проект";"Средний проект";"Крупный проект";"Очень крупный проект"}) выглядит необычно, но по сути второй аргумент {0;50;90;100}, как и третий аргумент {"Малый проект";"Средний проект";"Крупный проект";"Очень крупный проект"} это запись содержимого 4-х ячеек. Вместо {0;50;90;100} можно записать ссылку на диапазон ячеек, содержащих 4 значения 0;50;90;100. Круглые скобки нужны, чтобы сообщить, что в функцию передается не одно значение, а целый массив.

Еще пример. Пусть требуется вывести разный текст (например "<0"; "=0" или ">0") в случае наличия в ячейке А1 отрицательного значения, положительного значения или 0. Это можно сделать без вложенных ЕСЛИ():

=ПРОСМОТР(A1;{-1E+307;0;1E-307};{"<0";"=0";">0"})

Примечание : -1E+307 - это самое маленькое отрицательное число в EXCEL, 1E-307 - это самое маленькое положительное число. Таким образом задается 3 диапазона: от минус бесконечности до 0 (0 не включая); 0 (диапазон состоит только из одного значения 0); от 0 до +бесконечности (0 не включая).

Второй массив можно заменить ссылкой на диапазон, например для того чтобы вывести результат вычисления формул:

=ПРОСМОТР(A24;{-1E+307;0;1E-307};A27:A29)

Диапазон A27:A29 должен, понятно, содержать формулы (см. файл примера).

Опущен третий аргумент [значение_если_ложь]

Третий аргумент функции не обязателен. Если логическое условие не выполнено, т.е. ЛОЖЬ, а третий аргумент функции не указан, то функция вернет также значение ЛОЖЬ. Например:

=ЕСЛИ(A1>100;"Бюджет превышен")

Если в ячейке A1 содержится значение 1, то вышеуказанная формула вернет значение ЛОЖЬ.

Сложные логические выражения

В аргументе Лог_выражение можно использовать как простые сравнения типа F1>10, так и более сложные конструкции на основе функций И(), ИЛИ(), НЕ() и их комбинаций.

Основное правило - логические функции и их комбинации возвращают только одно из 2х логических значений: ЛОЖЬ или ИСТИНА.

Приведем несколько полезных примеров.

Формула =ЕСЛИ(ИЛИ(A1;A2);0;2) проверяет одновременность равенства значений А1 и А2 нулю. Если оба значения равны 0, то формула вернет 2. Во всех других случаях будет возвращен 0. А1 и А2 не должны быть пустыми ячейками.

Формула =ЕСЛИ(ИЛИ(A1=0;A2=0);0;2) проверяет равенство 0 хотя бы одного значения из А1 и А2.

Формула =ЕСЛИ(НЕ(A1>0);1;2) эквивалентна формуле =ЕСЛИ(A1<=0;1;2)

Вместо ИСТИНА или ЛОЖЬ в первом аргументе введено число

Т.к. значение ЛОЖЬ эквивалентно 0, то формулы =ЕСЛИ(0;"Бюджет превышен";"ОК!") или (если в ячейке A1 содержится значение 0) =ЕСЛИ(A1;"Бюджет превышен";"ОК!") вернут ОК!

Если в ячейке A1 находится любое другое число кроме 0, то формула вернет Бюджет превышен . Такой подход удобен, когда проверяется равенство значения нулю значения ячейки.

Примечание : чтобы убедиться, что логическое значение ЛОЖЬ соответствует 0 введите формулу =--А1=0. В А1 введите ЛОЖЬ. Формула вернет ИСТИНА. Отметим, что логическое значение ЛОЖЬ именно соответствует 0, но не равно 0, т.к. формула  =А1=0 вернет ЛОЖЬ, следовательно логическое значение ЛОЖЬ не равно 0. Железная логика!

Примечание : Двойное отрицание "--" - это просто математическая операция, которая приводит к преобразованию логического выражения в числовое, но не приводит к изменению самого значения. Двойное отрицание можно заменить сложением с 0 или возведением в первую степень: =(А1+0)=0.

Связь функции ЕСЛИ() с другими функциями использующие условия

EXCEL содержит также другие функции, которые можно применять для анализа данных с использованием условий. Например, для подсчета количества вхождений чисел в диапазоне ячеек используется функция СЧЁТЕСЛИ() , а для сложения значений, удовлетворяющих определенным условиям, используется функция СУММЕСЛИ() .

Функция ЕСЛИ() , как альтернативный вариант, может быть также использована для подсчета и сложения значений с использованием условий. Ниже приведены иллюстрирующие примеры.

Пусть данные находятся в диапазоне A6:A11 (см. файл примера)

Подсчитаем сумму значений, которые больше 10 с помощью функции СУММЕСЛИ() , записав =СУММЕСЛИ(A6:A11;">10") . Аналогичный результат (23) можно получить с помощью формулы массива =СУММ(ЕСЛИ(A6:A11>10;A6:A11)) (для ввода формулы в ячейку вместо ENTER нужно нажать CTRL+SHIFT+ENTER )

Теперь подсчитаем количество вхождений чисел больше 10 в диапазоне ячеек A6:A11 =СЧЁТЕСЛИ(A6:A11;">10") . Аналогичный результат (2) можно получить с помощью формулы массива =СЧЁТ(ЕСЛИ(A6:A11>10;A6:A11))

Теперь, когда принцип понятен, с помощью функции ЕСЛИ() можно конструировать и другие формулы с условиями. Например, нахождение минимального значения среди чисел больше 10: =МИН(ЕСЛИ(A6:A11>10;A6:A11))


Комментарии
Только для авторизованных пользователей

Аноним, 26 марта 2016 г.
Помогите мне пожалуйста. Со студенческих лет все позабылось... у меня есть таблица- в первом столбце название запчастей, второй столбец количество. Строк около 1000. Мне нужны только запчасти с количеством больше 1000. Что делать?!
Аноним, 26 мая 2016 г.
Помогите пожалуйста решить задачу. Если показатель в колонке АЕ >2.5 то значение должно стоять 2,5, если <, то такое же какое стоит в АЕ, а вот сама сложность с минусовыми результатами, если меньше (-2,5), то балы должны снижаться на 2,5 бала. Формула такая =ЕСЛИ(И(AE8>2,5);2,5;ЕСЛИ(AE8<2,5;AE8;ЕСЛИ(AE8<(-2,5);-2,5)))
Аноним, 2 июня 2016 г.
В Excel 2003 Можно использовать только 7 раз функцию "ЕСЛИ" в формуле в одну строчку
Аноним, 2 июня 2016 г.
ты сам понял что написал?)))
Аноним, 2 июня 2016 г.
Ну знаете, мне после 5-го "если" уже плохо, Так что он в чем-то прав 😃
Михаил, 10 июля 2016 г.
=ЕСЛИ(И(C8<2,5;C8>-2,5);C8;ЗНАК(C8)*ABS(C8))
Михаил, 10 июля 2016 г.
Вам лучше использовать http://excel2.ru/articles/avtofiltr-v-ms-excel
Михаил, 10 июля 2016 г.
Это я про автофильтр ))
Аноним, 11 июля 2016 г.
Спасибо большое! Сейчас то я и попробую подставить.....
Аноним, 11 июля 2016 г.
[id295933596|Михаил], Что-то не получилось, 2,5 не встало, как было -11, так и осталось.....
Михаил, 13 июля 2016 г.
Ну, номер ячейки С8, может Вы не исправили на свою АЕ8? Если все плохо, то можете файл отправить через нашу группу в Контакте vk.com/excel2ru
Аноним, 12 ноября 2016 г.
Помогите, пожалуйста! Если остаток товара составляет больше половины от реализованного, то выводим - «заказывать больше не надо»; если остаток составляет 20 % от поступления, то выводим – «требуется пополнить запасы»; если остаток составляет менее 10 процентов от поступления, то выводим – «срочный заказ».
Аноним, 14 декабря 2017 г.
Здравствуйте. Подскажите пожалуйста как написать формулу. Условия такие если от 0 до 39 то 2, от 40 до 64 то 3
Аноним, 15 августа 2019 г.
Помогите, плиз! ЕСЛИ_ИСТИНА - значение; ЕСЛИ_ЛОЖЬ- раскрывающийся список
Михаил, 17 августа 2019 г.
Сделайте Динамический список. Если ИСТИНА, то в списке только 1 значение. Если ЛОЖЬ, то список будет содержать несколько значений. Список возвращает значение, не формулу, поэтому для автоматической вставки значения, когда ИСТИНА без макроса не обойтись
Аноним, 12 декабря 2019 г.
Подскажите и мне, как правильно прописать формулу если в желтой "Цементно-печаные смеси", то формула b4=b2*1*b3/1000*1500 и так для пяти различных наименований
Михаил, 13 декабря 2019 г.
=если("Цементно-печаные смеси";b2*1*b3/1000*1500;"????????????????")
Аноним, 24 декабря 2019 г.
Здравствуйте! У меня вопрос как можно составить формулу с диапазоном значений по примеру- Если меньше 4 то 1, если 4,1-4,5 то 2, если 4,6-5,0 то 3, если 5,1-5,5 то 4, если выше 5,5 то 5 Заранее спасибо!!
Михаил, 24 декабря 2019 г.
В этой статье, в разделе Вложенные ЕСЛИ. См. формулу на основе ВПР
Аноним, 20 марта 2020 г.
Подскажите пожалуйста, как сделать: есть столбцы в которых считается общая прибыль, нужно сделать если значение меньше 10, то умножать на 1,1;1.2;1,3; и так далее, пока не будет значения больше 10,а если больше 200, то умножать на 0,9;0,8;0,7 и так далее... чет никак не получается своей дурной головой сообразить..(((
Михаил, 20 марта 2020 г.
не до конца понял. пусть в ячейке А1 есть 7. Чтобы получилось больше 10 нужно умножить 7 на 1,1, получится 7,7, затем 7,7 умножить на 1,2, и т.д. не проще ли умножать =$A$1*(1+0,1)^B1, в B1, С1, D1 и далее содержится ряд 1, 2, 3? это же сложные проценты со ставкой 10%? А что нужно найти? Год после которого значение больше 10? для этого есть формула https://excel2.ru/articles/slozhnye-procenty-v-ms-excel-postoyannaya-stavka
Аноним, 21 марта 2020 г.
[id295933596|Михаил], Спасибо, но не проценты. A1 производная из др ячеек (A1=B1*C1-E1), значение может быть меньше 10 и даже отрицательным, нужно в ячейке D1 прописать условия, если А1<10, то умножать на коэффициент до тех пор пока не будет > 10, а если будет > 200, то наоборот умножать на 0,9 или любой другой коэф. пока не получится <200...Примерно так D1=Если(A1<10, то С1*1,1, иначе на 0,9, и так пока не будет соблюден интервал от 10 до 200. В принципе без разницы можно и уменьшать на определенный шаг, например -10 или +10, просто мне процентное соотношение показалось более удачным...В итоге в ячейке D1 будет приводится пример рекомендуемой суммы для выполнения диапазона >10 <200... (=$A$1*(1+0,1)^B1, в B1, С1, D1 и далее содержится ряд 1, 2, 3?) А что указывать в B1? немного не понял формулу, я умножаю значение a1, которое может быть и отрицательным, на 10% и возвожу в степень?...
Михаил, 21 марта 2020 г.
[id295933596|Михаил], я разместил файл примера в нашей группе https://vk.com/excel2ru для отрицательных значений я не сделал, т.к. нужно вникать в суть задачи. Попробуйте по аналогии сделать с суммой, а не с множителем.
Аноним, 30 марта 2020 г.
Добрый день! Подскажите, пожалуйста, формулу суммы н-2,н-6. сумма показывает 0
Михаил, 2 апреля 2020 г.
Добрый день, EXCEL складывает только числа. Что такое "н" и что за запись н-2,н-6? Вот так EXCEL может: =СУММ(2;6) - вернет 8 Или =6+8 - вернет 14
Аноним, 14 апреля 2020 г.
Добрый день! Не могу разобраться с формулой: =ЕСЛИ(I25>0;ЕСЛИ(Q25>0;ABS(ЧИСТРАБДНИ.МЕЖД(I25;Q25;1;$E$1:$F$3));ABS(ЧИСТРАБДНИ.МЕЖД(I25;R25;1;$E$1:$F$3)));ЕСЛИ(G25>0;ЕСЛИ(Q25>0;ABS(ЧИСТРАБДНИ.МЕЖД(H25;Q25;1;$E$1:$F$3));ABS(ЧИСТРАБДНИ.МЕЖД(H25;R25;1;$E$1:$F$3)));"материалы_не_получены")) данная формула считает кол-во дней между начальной и конечной датой, но так бывает, что начальная дата = конечной дате, формула ставит в ячейку 0, а нужно автоматически ставить 1. Я понимаю, что нужно прописать формулу: Если результат текущего вычисления равен 0, то ставим 1, иначе снова текущая формула, но не получается это реализовать в данной формуле. Что нужно прописать и куда вставить? Спасибо
Аноним, 3 мая 2020 г.
Добрый вечер Подскажите формулу. Если значение в диапазоне А30:А150 = "Контент", то суммировало их значение из В30:В150
Аноним, 6 мая 2020 г.
Подскажите пожалуйста формулу в таком случае. У меня таблица состоит из 31 дня есть колонка каждых суток ПЛАН. И ФАКТ. И итог месяца, который считает за месяц солько он собрал всего. Пример человеку дают задание собрать за смену 230 яблок. По факту он собрал 230, то его премии должна идти надбавка на 10%. Или 0,1 (как удобно) Если задание план 230 он собирает 100, но на следующий день собирает 130. Формула должна прибавлять каждый раз по 0.10% (0,1) в течении месяца. Т.е. если каждый день итог в течении месяца идет 230 + 10%(0,1) затем собирает 460 то еще + 10%(0,1) и так в течении месяца. Что бы ему заработать положенную премию 100% ему за месяц надо собрать 2300. Короче каждые каждые 230 яблок, не важно за смену он собрал, или за 2-3 дня в колонке итог должно прибавлять ему 10%. Надеюсь понятно написал :)
Михаил, 6 мая 2020 г.
Подсказываю не формулу, а функцию - СУММЕСЛИ https://excel2.ru/articles/funkciya-summesli-slozhenie-s-odnim-kriteriem-v-ms-excel-chast1chislovoy-kriteriy-summesli
Михаил, 7 мая 2020 г.
это задача на логику, а не на применение EXCEL. Формул EXCEL здесь нет, только + да * не поможем.
Аноним, 15 мая 2020 г.
А если в ячейке содержится много слов, например: Фамилия Иванов, Накладная N 53, дата накладной 28.01.2020 и проч., а рядом стоит сумма, то как сделать, чтобы считывала только по фамилии. Это я выгрузила таблицу из 1С, а она выгружается именно так. То есть, в одной ячейке несколько данных.
Михаил, 15 мая 2020 г.
Добрый день, 1.Попробуйте запустить в EXCEL мастер разделения текстов. Подробнее здесь https://excel2.ru/articles/tekst-po-stolbcam-master-tekstov-v-ms-excel 2.Мне кажется, но 1С также может выгружать по разному, попробуйте из 1С выгрузить в разные ячейки. 3.Также можно разделить данные из ячейки формулами, но для этого нужно провести анализ текстовой строки. Подробнее здесь - набор статей на эту тему https://excel2.ru/gruppy-statey/izmenenie-tekstovyh-strok-znacheniy?utm_source=group_articles&utm_content=6
Аноним, 30 мая 2020 г.
Введите функцию, которая ЕСЛИ значение в синей ячейке равно пустой строке (т.е. =""), то возвращает "Данных нет", в противном случае "Данные есть" Подскажите пожалуйста формулу
Михаил, 30 мая 2020 г.
Пожалуйста =ЕСЛИ(И(ЕТЕКСТ(C12);ДЛСТР(C12)=0);"Данных нет";"Данные есть") Если ячейка на самом деле пуста, то формула вернет Данные есть. Но, я так понял, в Вашей ситуации такое невозможно.
Аноним, 14 июня 2020 г.
Здравствуйте, помогите составить формулу. Есть ячейка, указывающее прошедшее время с даты принятия и завершения заказа, т.е ДАТА СДАЧИ - ДАТА ЗАКАЗА= ВРЕМЯ ВЫПОЛНЕНИЯ. Но если дата сдачи не указана, то и срок выполнения отображается неверно, а нужно так, чтобы если не указана дата сдачи, то время выполнения равняется ТЕКУЩАЯ ДАТА - ДАТА ЗАКАЗА.
Михаил, 14 июня 2020 г.
Здравствуйте, если ДАТА ЗАКАЗА в столбце А, а Дата СДАЧИ в столбце В, то формула будет =ЕСЛИ(ЕПУСТО(B3);СЕГОДНЯ();B3)-A3
Аноним, 14 июня 2020 г.
Здравствуйте. Такая задачка. Нужно сравнить значение двух соседних ячеек с форматом "дата" на изменение. Составить формулу "если значение в ячейке А1 меньше чем в ячейке А2, то; сделать это; или это" проще простого. А если нужно учесть на сколько именно меньше? То есть если в ячейке А1 "январь 2022", а в ячейке А2 "сентябрь 2021", то нужно учесть пропущенные 2 месяца по определенной формуле. Как составить такую функцию? Заранее спасибо, если поняли что я имею в виду)
Аноним, 15 июня 2020 г.
[id295933596|Михаил], благодарю, очень помогли:) а возможно к этой формуле добавить условие что если результат больше определенного числа, то чтобы цвет цифр был красный?
Михаил, 15 июня 2020 г.
[id34608627|Сергей], можно. Это называется Условное форматирование. В 2-х словах не расскажешь. Вот здесь я подробно писал в статье https://excel2.ru/articles/uslovnoe-formatirovanie-v-ms-excel
Михаил, 15 июня 2020 г.
Здравствуйте. Может сначала вычислить разницу между датами, а затем сравнить ее с заданным числом дней?
Аноним, 16 июня 2020 г.
[id295933596|Михаил], да, я знал про него, но почему то подумал что там только заливку можно красить:) спасибо!
Аноним, 16 июня 2020 г.
[id295933596|Михаил], спасибо за идею, функцию со сравнением разницы в днях уже придумал, но хотелось бы именно сравнение в месяцах, а Excel при прямом вычитании дат считает именно количество дней. Не хотелось бы придумывать костыли, чтобы обойти разное количество дней в месяцах. Не знаете, есть ли способ считать именно разницу месяцев?
Михаил, 16 июня 2020 г.
[id889420|Лев], вот статья как вычислить разницу в месяцах https://excel2.ru/articles/ms-excel-skolko-polnyh-mesyacev-proshlo
Аноним, 16 июня 2020 г.
[id295933596|Михаил], спасибо, функция "разндат" помогла решить задачу, правда без костылей не обошлось). От того, что в зависимости от количества пройденных месяцев должна меняться формула, то общая формула для этой ячейки получилась оооочень длинной, так как каждый месяц прописывал отдельно. Поэтому сократил изменения на 1 год максимум, надеюсь больше не потребуется, но если что, допишу еще. Главное, что с задачей справляется) Спасибо вам большое)
Аноним, 13 июля 2020 г.
Михаил Петров,Вот такая задача. ЕСЛИ(V8<500000;V8*2,5%;ЕСЛИ(500000<V8<1020000;V8*10%-37500;ЕСЛИ(V8>1020000;64500))). Не могу составить формулу, в диапазоне 500000-1020000 дает значение <ЛОЖЬ>.Заранее спасибо.
Аноним, 14 июля 2020 г.
Добрый день подскажите почему формула выдает 31 - по общему количеству дней, а не рабочих смен. Данная формула считает количество смен =ЕСЛИ($A16<>"";СЧЁТЕСЛИ($AK16:$BO16;"<>0");"")
Михаил, 15 июля 2020 г.
Здравствуйте, без файла я не вижу содержимого ячеек АК-ВО. Т.к. формула выдает число 31, то проблема точно не в ЕСЛИ, а в СЧЕТЕСЛИ. Пишите в группу https://excel2.ru/
(только для авторизованных пользователей)

© Copyright 2013 - 2020 Excel2.ru. All Rights Reserved