Диаграмма Ганта в EXCEL с % выполнения и связями между работами

Построим диаграмму Ганта отображающую связанные работы и процент их выполнения.


Диаграмма Ганта в MS EXCEL часто используется при управлении проектами. Эта диаграмма может отображать:

  • перечень работ/ задач проекта;
  • плановую длительность работ;
  • связи между работами;
  • процент выполнения.

Процесс создания простейшей диаграммы Ганта без связей и % выполнения приведен в статье Диаграмма Ганта . Разовьем эти идеи для создания более совершенной диаграммы (см. файл примера ).

Пусть необходимо спланировать проект создания некого производства. Нужно выполнить ряд работ по проекту: провести конкурсы на приобретение оборудования, СМР (строительно-монтажные работы), ввести в эксплуатацию и др. Исходная таблица содержит перечень работ, дату начала работ (или ссылку на работу-предшественника), длительность, % выполнения.

Как и в статье Диаграмма Ганта будем использовать диаграмму Линейчатая с накоплением . Т.к. на диаграмме теперь будем отображать и процент выполнения, то потребуется добавить еще один ряд данных и несколько столбцов в исходной таблице: Начало работы (фиксированная дата начала выполнения работы), Выполнено (число дней соответствующее проценту выполнения работы), Не выполнено (столбец длительность минус столбец выполнено ).

Источник данных для диаграммы теперь будет выглядеть так:

Обычно предполагается, что работы в проекте логически связаны. Например, работа Разработка проекта начинается только после проведения конкурса по определению организации проектировщика, т.е. завершения работы Проведение конкурса . Реализуем связь начало-конец , т.е. когда начало одной работы связано с окончанием работы-предшественника. Также учтем возможную задержку между началом выполнения работы и окончанием работы-предшественника.

В исходной таблице создадим еще несколько дополнительных столбцов: Код работы; Работа-предшественник; Задержка . Если раньше в столбце Начало работы были фиксированные даты начала выполнения работы, то теперь заменим их формулой =ЕСЛИ(C6<>"";C6;ИНДЕКС($I$6:$I$10;ПОИСКПОЗ(D6;$B$6:$B$10;0))+E6+1)

Теперь, если задана фиксированная дата в столбце Начало , то в столбце Начало работы отобразится именно она. Если задана работа-предшественник, то будет определена дата окончания этой работы, учтена задержка и прибавлен 1 день.

Например, окончание работы Проведение конкурса запланировано на 21.03.2010. Для определения даты начала работы-последователя Разработка проекта вышеуказанная формула в столбце Начало работы (ячейка H 7 ) к сроку окончания прибавит 5-и дневную задержку и еще 1 день, чтобы связанная работа начиналась на следующий день. Получим 27.03.2010.

Теперь, после определения связей, при изменении длительности работы Проведение конкурса, скажем на 30 дней, получим соответствующий сдвиг у всех работ-последователей.

СОВЕТ : Для начинающих пользователей EXCEL советуем прочитать статью Основы построения диаграмм в MS EXCEL , в которой рассказывается о базовых настройках диаграмм, а также статью об основных типах диаграмм .


Комментарии
Только для авторизованных пользователей

(только для авторизованных пользователей)

© Copyright 2013 - 2020 Excel2.ru. All Rights Reserved