Выделяем дни недели цветом в EXCEL

С помощью Условного форматирования выделим фон ячеек, содержащих дни недели Суббота и Воскресенье, красным цветом.


Пусть в столбце А содержится перечень дат. Выделим ячейки , содержащие дни недели Суббота и Воскресенье, красным цветом (см. файл примера ).

Выделять ячейки будем с помощью правил Условного форматирования . В зависимости от содержимого ячейки (дата, текст или число) правила будут разными.

В ячейке содержится Дата

В столбце А содержатся значения в формате дата, например в ячейке А6 - 13.08.2012.

Чтобы настроить правило Условного форматирования нужно:

  • выделить диапазон А6:А14
  • выбрать пункт меню Главная/ Стили/ Условное форматирование/ Создать правило...
  • выбрать тип правила Использовать формулу для определения форматируемых ячеек
  • в поле Форматировать значения, для которых следующая формула является истинной ввести формулу =ДЕНЬНЕД(A6;2)>5
  • задать формат, например красную заливку фона ячейки.

Даты в столбце А , у которых номер дня недели >5, будут выделены красным.

В ячейке с пользовательским форматом ДДД или ДДДД содержится Дата



Пусть в столбцах B и С также содержатся значения в формате дата, например в ячейке B6 введем формулу =A6 .

Для ячеек в диапазоне B6:B14 настроим пользовательский формат ДДД (для диапазона С6:С14 ДДДД).

Не смотря на то, что теперь в ячейках отображаются Пн и Понедельник, значения в ячейках продолжают оставаться в формате Дата. В этом можно убедиться скопировав значение ( CTRL+V ), например, из ячейки С6 , и вставив его Как значение ( Главная/ Буфер обмена/ Вставить / Вставить значение ). В Строке формул будет отображаться значение 13.08.2012, а не слово понедельник . Поэтому настраивать правило Условного форматирования нужно так как показано в предыдущем разделе.

В ячейке содержится Число

Пусть в столбце D содержится номер дня недели, например в ячейке D6 введем формулу =ДЕНЬНЕД(A6;2) .

В этом случае правило Условного форматирования настраивается аналогично случаю когда в ячейке содержится Дата, только несколько упрощается формула =$D6>5

В ячейке содержится Текстовое значение

Пусть в столбце E содержится день недели в текстовом формате, например слово Понедельник.

В этом случае правило Условного форматирования настраивается с помощью формулы =ИЛИ($E6="суббота";$E6="воскресенье")

Комментарии
Только для авторизованных пользователей

Аноним, 7 августа 2016 г.
Спасибо огромное!!Вы мне очень помогли!!!!!
Аноним, 25 февраля 2018 г.
А если нужно выделить не субботу и воскресенье, а на пример понедельник и среду. Как быть? Подскажите пожалуйста!
Михаил, 27 февраля 2018 г.
=ИЛИ(ДЕНЬНЕД(...)=1;ДЕНЬНЕД(...)=3)
Аноним, 20 июля 2019 г.
Добрый день, ка написант в одном ичейке дата и день неделе вместе. Например "30. авг. пятница 2019" или "30. авг. пт 2019" Или как небудь, Спасибо, Уважением, Динеша
Михаил, 21 июля 2019 г.
Добрый день, На пустом листе в ячейке А1 введите дату В любой другой ячейке на этом листе введите формулу =ТЕКСТ(A1;"дд. МММ. дддд гггг")
(только для авторизованных пользователей)

© Copyright 2013 - 2020 Excel2.ru. All Rights Reserved