Пользовательский формат ДАТЫ и ВРЕМЕНИ в EXCEL

Пользовательский формат – это формат отображения значения задаваемый пользователем. Например, дату 13/01/2010 можно отобразить как: 13.01.2010 или 2010_01_13 или 13-Январь-10 .


Пользовательский формат можно применить через Формат ячеек или определить в функции ТЕКСТ() . В этой статье приведены некоторые примеры пользовательского формата даты и времени (см. файл примера ).

Форматы Даты (на примере значения 01.02.2010 12:05)

Формат

Название

Результат для 01.02.2010 12:05

М

Месяц (заглавная буква М)

2

ММ

месяц

02

МММ

фев

ММММ

Февраль

д

день

1

дд

01

ддд

сокращенный день недели

Пн

дддд

день недели

понедельник

д.М

1.2

гг (или г)

год

10

гггг (или ггг)

2010

д.М.гг

1.2.10

дд.ММ.гггг чч:мм

полный формат даты

01.02.2010 12:05

ДД МММ ГГГГ

01 фев 2010

дд-ММ-гггг

01-02-2010

ГГГГ\_ММ\_ДД

Пользовательский формат

2010_02_01

ДДД, ДД|ММ|ГГ Пользовательский формат Пн, 01|02|10

ДД-ММММ-ГГ

Пользовательский формат

13-Январь-10

Форматы времени (на примере значения 12:05 дня)



Формат

Название

Результат для 12:05 дня

м

минуты

5

мм

минуты

05

ч:мм AM/PM

12:05 PM

ч:мм:сс

12:05:00

[ч]

подсчет кол-ва часов

12

[м]

подсчет кол-ва минут

725 (12*60+5)

Пользовательский формат не влияет на вычисления, меняется лишь отображения числа в ячейке. Пользовательский формат можно ввести через диалоговое окно Формат ячеек , вкладка Число , ( все форматы ), нажав CTRL+1 . Сам формат вводите в поле Тип , предварительно все из него удалив. Более подробно о применении пользовательского формата читайте в статье Числовой пользовательский формат .

В случае использования функции ТЕКСТ() используйте следующий синтаксис: =ТЕКСТ(СЕГОДНЯ();"здесь укажите требуемый формат") . Например, =ТЕКСТ(СЕГОДНЯ();"дд.ММ.гггг")

Естественно, вместо функции СЕГОДНЯ() можно использовать либо дату, либо формулу, вычисление которой дает числовое значение, представляющее собой дату, либо ссылку на ячейку, содержащую дату. О том, как EXCEL хранит дату и время можно прочитать в одноименной статье Как Excel хранит дату и время .

Еще один пример: число 1300 можно отобразить как Время (13:00) с помощью формата 00\:00 (обратный слеш нужен для корректного интерпретирования двоеточия). Результат 13:00. Но EXCEL будет продолжать производить вычисления с 1300 как с обычным числом (меняется только отображения числа 1300). При прибавлении 65 вместо 14:05 получим 13:65. Аналогичная функция с пользовательским форматом: =ТЕКСТ(1300;" 00\:00")

Этот формат полезен для ускорения ввода, см. статью Ускорение ввода значений в формате времени .


Комментарии
Только для авторизованных пользователей

Аноним, 31 января 2016 г.
Помогите, пожалуйста. Нажала Ctrl1. Ввела новый формат ГГГГ.ММ.ДД Нажала ок. В ячейке вместо даты пишет кучу решёток. В поле образец формы Формат ячеек также пишет кучу решёток. Более того, сбились все форматы даты. Теперь все даты мне решётки показывают. Что делать?
Аноним, 17 февраля 2016 г.
Увеличить размер ячейки и все будет нормально) Решетки означают то, что число не помещается в размер ячейки.
Аноним, 3 июня 2016 г.
Добрый вечер! Подскажите пожалуйста как оформить в строку числа месяца и дни недели.
Аноним, 8 июня 2016 г.
Здравствуете, подскажите как сделать чтоб не нужно было нажимать постоянно : при вводе время, у Вас я нашёл как сделать при вводе часов и минут #":"00 , но мне необходимо вводить ещё и секунды
Аноним, 8 июня 2016 г.
Я разобрался сам )) #":"00":"00
Михаил, 10 июля 2016 г.
Если я правильно понял, то нужно в ячейке одновременно вывести и число и день недели. Это нельзя сделать Форматом ячейки, только формулой =ТЕКСТ(A1;"д")&"/"&ТЕКСТ(A1;"ддд")
Михаил, 10 июля 2016 г.
Роман, вы не правы. Если в поле Образец Формата ячеек отображаются #####, то это значит значение в ячейке не может быть преобразовано в дату. Увеличение ширины столбца не поможет. Например, введите число 23242342354353: любой формат даты будет показывать ####. Формат Юлия ввела правильно. Почему сбились форматы дат - не понятно. Нужен файл.
(только для авторизованных пользователей)

© Copyright 2013 - 2020 Excel2.ru. All Rights Reserved