Выделение в таблице EXCEL групп однотипных данных

Файл примера

С помощью Условного форматирования можно выделить данные, принадлежащие разным группам.


Предположим, что имеется таблица квартальных продаж по отделам (три столбца: О тдел, Квартал и Сумма продаж , в диапазоне А1:С17 ). См. файл примера .

Нам нужно отделить линией данные принадлежащие разным отделам. Проще всего это сделать с помощью Условного форматирования , устанавливая Границы ячеек .

Для этого необходимо:

  • отсортировать данные по столбцу Отдел ;
  • в таблице удалить все границы ячеек (по крайней мере все горизонтальные);
  • выделить все данные в таблице за исключением первой строки и строки с заголовками ;

  • Вызвать команду меню Условное форматирование/ Создать правило / Использовать формулу для определения форматируемых ячеек ;
  • в поле « Форматировать значения, для которых следующая формула является истинной » ввести =$A3<>$A4 ;
  • нажать кнопку Формат ;
  • выбрать вкладку Граница ;
  • убрать все границы;
  • выбрать цвет, например, Красный ;
  • установить нижнюю границу;
  • Нажать ОК.

В результате будем иметь следующую таблицу:

При добавлении в таблицу новых строк, правило Условного форматирования распространится и на них.

СОВЕТ: Для организации печати разных групп данных на отдельных листах используйте идеи из одноименной статьи Печать разных групп данных на отдельных листах .

Другой пример (выделение строк, относящихся к разным месяцам)

Предположим, что имеется таблица с датами продаж, даты продаж могут повторяться. Выделим Условным форматированием продажи, относящиеся к одной дате, одним цветом, т.е. так как показано на рисунке ниже (см. файл примера, лист Пример2 ). Столбец Дат должен быть отсортирован .

Для этого создадим вспомогательный столбец с формулой =ЕСЛИ(A8<>A7;НЕ(D7);D7) . В ячейке D7 введем значение ИСТИНА. Значения ИСТИНА и ЛОЖЬ будут соответствовать цвету заливки ячеек.

Столбец помогает отследить момент, когда изменяется дата. При изменении даты ИСТИНА меняется на ЛОЖЬ и наоборот, тем самым правилу Условного форматирования дается команда поменять цвет заливки строк таблицы .

Само правило имеет простейший вид.

Не забудьте установить смешанную ссылку при вводе формулы =$D7

Примечание . Про выделение дат, относящихся к одному и тому же месяцу можно прочитать в этой статье .

Файл примера

© Copyright 2013 - 2020 Excel2.ru. All Rights Reserved