Выбор в EXCEL из ФИО имени и имени с отчеством

Если строка в ячейке содержит ФИО, например, «Петров Василий Иванович», то можно создать формулу для вывода имени или имени с отчеством.


Пусть текстовая строка Петров Василий Иванович находится в ячейке A 1 . Выведем имя (см. файл примера ): =СЖПРОБЕЛЫ(ПСТР(A1;ПОИСК(" ";A1);ПОИСК(" ";A1;ПОИСК(" ";A1)+1)-ПОИСК(" ";A1)))

или так: =ЕСЛИ(ДЛСТР(A1)-ДЛСТР(ПОДСТАВИТЬ(A1;" ";""))=1;"";СЖПРОБЕЛЫ(ПСТР(A1; ПОИСК(" ";A1);ПОИСК(" ";A1;ПОИСК(" ";A1)+1)-ПОИСК(" ";A1))))

Выведем имя и отчество: =ПРАВСИМВ(A1;ДЛСТР(A1)-ПОИСК(" ";A1))

Понятно, что для работы формул необходимо жестко соблюдать порядок слов: сначала фамилия, затем имя с отчетством.

Вообще, хранить несколько текстовых значений в одной ячейке неправильно, отсюда и возникают такого рода задачи, имеющие громоздкие решения (см. Советы по построению таблиц в MS EXCEL ).

Как альтернативу можно посоветовать воспользоваться инструментом Текст-По-Столбцам ( Данные/Работа с данными ), позволяющему, разделить текстовую строку на несколько строк.

Если необходимо из текстовой строки вывести первое слово, то читайте статью Выбор из строки первого слова .

Если необходимо из текстовой строки вывести последнее слово, то читайте статью Выбор из строки последнего слова .

© Copyright 2013 - 2020 Excel2.ru. All Rights Reserved