Выбор в EXCEL из строки первого слова

Если строка в ячейке содержит ФИО, например, «Петров Василий Иванович», то можно создать формулу для вывода первого слова (фамилии).


Пусть текстовая строка Петров Василий Иванович находится в ячейке A 1 . Выведем фамилию (см. файл примера ): =ЛЕВСИМВ(A1;ПОИСК(" ";A1)-1)

Перед применением формулы убедитесь, что в строке нет лишних пробелов. Это можно сделать функцией СЖПРОБЕЛЫ() .

Число слов в строке д.б. два и более. Если нет гарантии, что в строке есть хотя бы два слова, то нужно использовать другую формулу: =ЕСЛИОШИБКА(ЛЕВСИМВ(A1;ПОИСК(" ";A1)-1);A1)

или такую (для EXCEL 2003)

=ЕСЛИ(ЕОШИБКА(ПОИСК(" ";A1)-1);A1;ЛЕВСИМВ(A1;ПОИСК(" ";A1)-1))

Как альтернативу можно посоветовать воспользоваться инструментом Текст-По-Столбцам ( Данные/Работа с данными ), позволяющему, разделить текстовую строку на несколько строк.

Если необходимо из текстовой строки вывести последнее слово, то читайте статью Выбор из строки последнего слова .


© Copyright 2013 - 2020 Excel2.ru. All Rights Reserved