Возраст или стаж в годах в EXCEL

Файл примера

Определим возраст (или стаж) в полных годах.


Для вычислений длительностей интервалов дат удобней всего использовать недокументированную функцию РАЗНДАТ() . Этой функции нет в справке EXCEL 2007 и в Мастере функций ( SHIFT+F3 ), но она работает (с некоторыми огрехами).

Если в ячейке В6 содержится сегодняшняя дата (используйте формулу =СЕГОДНЯ() ), а в А6 – дата рождения (или дата начала работы), то формула =РАЗНДАТ(A62;B6;"y") вернет количество полных лет (или стаж).

Альтернативным вариантом является использование следующего выражения (см. файл примера ): =ЕСЛИ(ДАТА(ГОД(B6);МЕСЯЦ(A6);ДЕНЬ(A6))<=B6; ГОД(B6)-ГОД(A6);ГОД(B6)-ГОД(A6)-1)

Альтернативная формула работает так: если день рождения в текущем году уже наступил, т.е. ДАТА(ГОД(B2);МЕСЯЦ(A2);ДЕНЬ(A2))<=B2 , то разница годов будет равна полному количеству лет, а если нет, то от этой разницы нужно отнять 1.

Чтобы определить возраст или стаж с точностью до дней, читайте статью Сколько лет, месяцев, дней прошло с конкретной даты .

Примечание . Функция РАЗНДАТ() считает, что между датами 01.01.2014 и 31.12.2014 полного года не прошло. Формула =ОТБР(ДНЕЙ360(A6;B6)/360 ), напротив, считает. что прошел 1 год, однако, для пар дат 28.02.1987 и 27.02.1988; 28.02.1987 и 28.02.1988; 28.02.1987 и 29.02.1988 - так не считает (сказывается високосный год ).

В статье Расчет страхового (трудового) стажа в MS EXCEL показано как рассчитать стаж в годах, месяцах и днях.

Файл примера

© Copyright 2013 - 2020 Excel2.ru. All Rights Reserved