Високосный ли год в EXCEL (сколько дней в году?)

Файл примера

Определим число дней в году (365 или 366).


Для нахождения числа дней в году используем тот факт, что високосные года делятся нацело на 4. Пусть в А1 находится дата, например, 01/03/2010, тогда нижеуказанная формула вернет число дней в году: =ЕСЛИ(ОСТАТ(ГОД(A1);4);365;366)

Формула работает в диапазоне 1901-2099гг. Т.к. согласно действующего Григорианского календаря:

  • год, номер которого кратен 4 —високосный;
  • но год, номер которого кратен 100 — не високосный;
  • но год, номер которого кратен 400 — високосный;

Например, 2100 год не является високосным – формула же будет считать его високосным (см. файл примера ).

Файл примера

© Copyright 2013 - 2020 Excel2.ru. All Rights Reserved