Високосный ли год в MS EXCEL (сколько дней в году?)

Определим число дней в году (365 или 366).

Для нахождения числа дней в году используем тот факт, что високосные года делятся нацело на 4. Пусть в А1 находится дата, например, 01/03/2010, тогда нижеуказанная формула вернет число дней в году:
=ЕСЛИ(ОСТАТ(ГОД(A1);4);365;366)

Формула работает в диапазоне 1901-2099гг. Т.к. согласно действующего Григорианского календаря:

  • год, номер которого кратен 4 —високосный;
  • но год, номер которого кратен 100 — не високосный;
  • но год, номер которого кратен 400 — високосный;

Например, 2100 год не является високосным – формула же будет считать его високосным (см. файл примера).

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 4 (2 оценок)

Комментарии

MCH

"Для нахождения числа дней в году используем тот факт, что високосные года делятся нацело на 4" - это не корректно, лучше воспользоваться формулой:
=337+ДЕНЬ(ДАТА(ГОД(A1);3;))

Creator

Совершенно не согласен, с Вашим комментарием: для 1901-2099 годов формула работает безошибочно. Я не поленился и для каждого года вычислил напрямую количество дней =ДАТА(A1;12;31)-ДАТА(A1;1;1)+1 и сравнил с результатом формулы =ЕСЛИ(ОСТАТ(A1;4);365;366) В ячейке А1 содержится не дата, а просто год. Ваша формула, кстати, тоже работает корректно и причем для любых лет, а не только для 1901-2099 годов. Спасибо.