Високосный ли год в EXCEL (сколько дней в году?)

Определим число дней в году (365 или 366).


Для нахождения числа дней в году используем тот факт, что високосные года делятся нацело на 4. Пусть в А1 находится дата, например, 01/03/2010, тогда нижеуказанная формула вернет число дней в году: =ЕСЛИ(ОСТАТ(ГОД(A1);4);365;366)

Формула работает в диапазоне 1901-2099гг. Т.к. согласно действующего Григорианского календаря:

  • год, номер которого кратен 4 —високосный;
  • но год, номер которого кратен 100 — не високосный;
  • но год, номер которого кратен 400 — високосный;

Например, 2100 год не является високосным – формула же будет считать его високосным (см. файл примера ).

Комментарии
Только для авторизованных пользователей

Аноним, 17 декабря 2016 г.
Количество дней в григорианском календаре A1- дата =366-ОСТАТ(ЗНАК(ОСТАТ(ГОД(A1);4))+ЗНАК(ОСТАТ(ГОД(A1);100))+ЗНАК(ОСТАТ(ГОД(A1);400));2)
Михаил, 19 декабря 2016 г.
Протестировал формулу, косяков не заметил. Браво!
Аноним, 31 августа 2017 г.
То ли плакать, то ли смеяться с комментария MCH — наличие 29 февраля внутри функции определяется согласно тому, високосный ли год, а високосный год определяется по общеизвестной формуле, зависящей от остатка деления на 4, 100 и 400.
Михаил, 2 сентября 2017 г.
Мы здесь над комментами не смеемся, мы здесь стараемся писать формулы без ошибок. Формула уважаемого МСН работает
Аноним, 9 ноября 2017 г.
проверка, является ли год високосным: "=МЕСЯЦ(ДАТА(2016;2;29))=2" Если год не високосный, дата будет обращаться в 1 марта и формула вернет ЛОЖЬ
Аноним, 27 сентября 2019 г.
E2 - год. Проверяйте =ЕСЛИ(ОСТАТ(E2;400)=0;366;ЕСЛИ(ОСТАТ(E2;100)=0;365;ЕСЛИ(ОСТАТ(E2;4)=0;366;365)))
(только для авторизованных пользователей)

© Copyright 2013 - 2020 Excel2.ru. All Rights Reserved