Сложение значений в EXCEL на основании их повторяемости (Часть2.Сложение Неповторяющихся)

Диапазон суммирования содержит повторяющиеся значения. Сложим только те ЧИСЕЛа, которые не имеют повторов.


В качестве диапазона суммирования возьмем диапазон ( А2:А10 ), содержащий повторяющиеся значения : 986 ; 456; 67; 1 ; 34 ; 689 ; 456; 56 ; 67

Подсчитаем сумму только неповторяющихся значений.

Используем формулу массива : =СУММ(ЕСЛИ(СЧЁТЕСЛИ(A2:A10;A2:A10)=1;A2:A10;""))

Эту формулу необходимо ввести как формулу массива , т.е. после ввода формулы, нужно вместо ENTER нажать CTRL + SHIFT + ENTER .

О том как выделить неповторяющиеся значения написано в одноименной статье Выделение неповторяющихся значений .

СОВЕТ: О сложении уникальных значений можно прочитать здесь . О сложении повторяющихся значений можно прочитать здесь .

Комментарии
Только для авторизованных пользователей

(только для авторизованных пользователей)

© Copyright 2013 - 2020 Excel2.ru. All Rights Reserved