Сложение значений в EXCEL на основании их повторяемости (Часть1.Сложение Уникальных)

Пусть диапазон суммирования содержит повторяющиеся значения. Произведем сложение ЧИСЕЛ без учета повторов.


В качестве диапазона суммирования возьмем диапазон ( А2:А10 ), содержащий повторяющиеся значения: 968; 456 ; 67 ; 1;  34; 689; 456; 56; 67

Подсчитаем сумму только уникальных значений, т.е. в диапазоне суммирования не будем учитывать повторы, т.е. 456; 67.

Для решения этой задачи потребуются функции СУММПРОИЗВ() , ЕСЛИ() и ЧАСТОТА() . Формула для сложения только уникальных значений выглядит так: =СУММПРОИЗВ(ЕСЛИ(ЧАСТОТА(A2:A10;A2:A10)>0;A2:A10))

  • функция ЧАСТОТА() необходима для определения уникальных значений. При первом вхождении заданного значения эта функция возвращает число, равное числу вхождений данного значения. Для каждого последующего вхождения того же значения функция возвратит 0 (ноль);
  • функция ЕСЛИ( ) для отбора ненулевых значений;
  • функция СУММПРОИЗВ() используется для сложения уникальных значений.

Другой вариант – формула массива : =СУММ(ЕСЛИ(ЧАСТОТА(A2:A10;A2:A10)>0;A2:A10))

Эту формулу необходимо ввести как формулу массива , т.е. после ввода формулы, нужно вместо ENTER нажать CTRL + SHIFT + ENTER .

О том как выделить уникальные значения написано в одноименной статье Выделение уникальных значений .

СОВЕТ: О сложении неповторяющихся значений можно прочитать здесь . О сложении повторяющихся значений можно прочитать здесь .


Комментарии
Только для авторизованных пользователей

(только для авторизованных пользователей)

© Copyright 2013 - 2020 Excel2.ru. All Rights Reserved