Склоняем правильно в EXCEL - 1 год, 2 года, 5 лет

Учимся корректно записывать число лет: 1 год, 2 года, 5 лет, 11 лет.


Для правильного написания год/ лет/ года необходимо написать формулу: =ЕСЛИ(И(ОСТАТ(A2;100)>=11;ОСТАТ(A2;100)<=14);"лет";ВПР(ОСТАТ(A2;10);{0;"лет":1;"год":2;"года":5;"лет"};2))

Разберем подробнее (см. Файл примера ):

  • Года, оканчивающиеся на цифру 1 (1, 21, 31 и т.д.), должны записываться как 1 год, 21 год и т.д.
  • Года, оканчивающиеся на цифры 2, 3, 4 (2, 22, 32, 3, 23, 4, 24 и т.д.), должны записываться как 2 года, 22 года, 3 года, 44 года и т.д.
  • Все остальные года должны записываться со словом лет: 5 лет, 10 лет, 69 лет, 667 лет и т.д.
  • Часть формулы ВПР( ОСТАТ(A2;10) ;{0;"лет":1;"год":2;"года":5;"лет"};2) определяет цифру, на которую заканчивается год ОСТАТ(A2;10) , затем, с помощью функции ВПР() выбирает из двухмерного массива констант {0;"лет":1;"год":2;"года":5;"лет"} слово год, лет или года .
  • Исключением являются года 11, 12, 13, 14, 111, 913, 2012 и т.д. Часть формулы ОСТАТ(A2;100)>=11;ОСТАТ(A2;100)<=14 определяет является ли год в ячейке А2 исключением.

СОВЕТ: Склонять правильно количество месяцев и дней поможет статья Склоняем правильно количество месяцев и дней .

Примечание: Благодарим нашего пользователя MCH за подсказку и исправление ошибки при решении этой задачи.


Комментарии
Только для авторизованных пользователей

Аноним, 28 мая 2020 г.
ЕСЛИ(ЗНАЧЕН(ПРАВСИМВ(D20;1))=0;"лет";ТЕКСТ(ЗНАЧЕН(ПРАВСИМВ(D20;1));"[=1]\го\д;[<5]\го\да;лет"))
Аноним, 28 мая 2020 г.
В ячейке D20 любое число, если на конце 1 - это год, если 0 или свыше 4-х - лет, остальное - года )))
Михаил, 29 мая 2020 г.
да, в интернете много решений такой задачи
(только для авторизованных пользователей)

© Copyright 2013 - 2020 Excel2.ru. All Rights Reserved