Склоняем правильно в EXCEL число месяцев и дней (1 месяц, 2 месяца, 10 месяцев)

Учимся корректно склонять число месяцев: 1 месяц, 2 месяца, 10 месяцев, 1 день, 2 дня, 10 дней.


Для правильного склонения числа месяцев необходимо написать формулу: =ЕСЛИ(И(ОСТАТ(A2;100)>=11;ОСТАТ(A2;100)<=14);"месяцев";ВПР(ОСТАТ(A2;10);{0;"месяцев":1;"месяц":2;"месяца":5;"месяцев"};2))

Для правильного склонения числа дней необходимо написать подобную формулу:

=ЕСЛИ(И(ОСТАТ(A2;100)>=11;ОСТАТ(A2;100)<=14);"дней";ВПР(ОСТАТ(A2;10);{0;"дней":1;"день":2;"дня":5;"дней"};2))

Разберем подробнее (см. Файл примера ):

  • Месяцы, оканчивающиеся на цифру 1 (1, 21, 31 и т.д.), должны записываться как 1 месяц, 21 месяц и т.д.
  • Месяцы, оканчивающиеся на цифры 2, 3, 4 (2, 22, 32, 3, 23, 4, 24 и т.д.), должны записываться как 2 месяца, 22 месяца, 3 месяца, 44 месяца и т.д.
  • Все остальные месяцы должны записываться со словом месяцев: 5 месяцев, 10 месяцев, 69 месяцев, 667 месяцев и т.д.
  • Часть формулы ВПР(ОСТАТ(A2;10);{0;"месяцев":1;"месяц":2;"месяца":5;"месяцев"};2) определяет цифру, на которую заканчивается год ОСТАТ(A2;10) , затем, с помощью функции ВПР() выбирает из двухмерного массива констант {0;"месяцев":1;"месяц":2;"месяца":5;"месяцев"} слово месяц, месяца или месяцев.
  • Исключением являются месяца 11, 12, 13, 14, 111, 913 и т.д. Часть формулы ОСТАТ(A2;100)>=11;ОСТАТ(A2;100)<=14 определяет является ли месяц в ячейке А2 исключением.

СОВЕТ: Склонять правильно количество лет (год, лет, года) поможет статья Склоняем правильно количество лет .


Комментарии
Только для авторизованных пользователей

(только для авторизованных пользователей)

© Copyright 2013 - 2020 Excel2.ru. All Rights Reserved