Поиск значения в EXCEL с максимальной или минимальной длиной строки

Файл примера

Найдем в списке текстовых значений строку с максимальной / минимальной длиной .


Пусть имеется список текстовых значений, среди которых нужно найти значение с максимальной длиной строки. Список значений находится в диапазоне A4:A12 (см. Файл примера ).

Сначала найдем максимальную длину строки с использованием формулы массива : = МАКС(ДЛСТР(A4:A12))

Теперь найдем значение, имеющее максимальную длину строки, точнее первое значение.

Задача

Решение

Первое сверху значение, имеющее максимальную длину

= ИНДЕКС(A4:A12;ПОИСКПОЗ(МАКС(ДЛСТР(A4:A12)); ДЛСТР(A4:A12);0))

Первое сверху значение, имеющее минимальную длину

= ИНДЕКС(A4:A12;ПОИСКПОЗ(МИН(ДЛСТР(A4:A12)); ДЛСТР(A4:A12);0))

Примечание . Вышеуказанную задачу можно решить без использования формулы массива , но для этого потребуется создать дополнительные столбцы с формулой ДЛСТР(A4) , затем найти максимальное значение.

В общем случае значений с максимальной длиной строки м.б. несколько. Иногда требуется вывести все эти значения в соседнем столбце. Об этом читайте в статье Поиск значений с максимальной длиной строки .

Файл примера

© Copyright 2013 - 2020 Excel2.ru. All Rights Reserved