Подсчет количества ячеек, содержащих ошибки в EXCEL

Бывает, что формулы возвращают ошибки (#ДЕЛ/0!, #Н/Д, #ЗНАЧ! и т.д.) Подсчитаем, количество ячеек, содержащих ошибки.


Подсчитаем количество ячеек, содержащих все ошибки кроме ошибки #Н/Д (см. файл примера ): = СУММПРОИЗВ(--ЕОШ(A2:A10))

Выделив в Строке формул выражение --ЕОШ(A2:A10) и нажав клавишу F9 получим массив , например: {1:1:0:1:1:0:1:0:0}. Единице соответствует значение ошибки.

Аналогичный результат можно получить и с использованием формулы массива : = СУММ(ЕСЛИ(ЕОШ(A2:A10);1))

Подсчитаем количество ячеек, содержащих все ошибки: = СУММПРОИЗВ(--ЕОШИБКА(A2:A10))

СОВЕТ: Для выделения ячеек содержащих ошибки используйте правило Условного форматирования . Для этого:

  • Выделите требуемый диапазон ячеек, например А2:А10
  • Вызовите инструмент Условное форматирование ( Главная/ Стили/ Условное форматирование/ Создать правило )
  • В появившемся окне выберите пункт Форматировать только ячейки, которые содержат
  • В качестве условия выберите Ошибки

СОВЕТ: Скрытие ошибок в ячейках рассмотрено в этой статье .


Комментарии
Только для авторизованных пользователей

Аноним, 25 мая 2017 г.
спасибо
(только для авторизованных пользователей)

© Copyright 2013 - 2020 Excel2.ru. All Rights Reserved