Отбор строк таблицы EXCEL по их номеру

Для извлечения из таблицы только нужных строк можно использовать формулы, а не только Автофильтр . Покажем преимущества и недостатки обеих подходов.


Пусть имеется исходная таблица с объемами продаж товаров по кварталам.

Нам требуется отобразить только строки с определенными номерами: 2, 3, 5, 10.

Это можно легко сделать с помощью Автофильтра в столбце А. Но. если нам требуется вывести строки не в исходной таблице, а например, на другом листе или при выводе строк отобразить не значения продаж за квартал, а продажи нарастающим итогом ?

В этом случае можно воспользоваться Сводными таблицами или формулами. В этой статье воспользуемся формулами для того, чтобы сформировать своеобразный Отчет на основе исходной таблицы.

Выведем требуемые строки на том же листе

Сделаем заготовку таблицы, в левом столбце укажем строки, которые требуется вывести.

В ячейке В22 введем формулу =ИНДЕКС(B$8:B$17;ПОИСКПОЗ($A22;$A$8:$A$17;0)) и скопируем ее для всех кварталов и строк.

Примечание : Обратите внимание на смешенные ссылки B$8:B$17 и $A22 - это важно при копировании формулы.

При необходимости можно подсчитать суммарные продажи за год (см. файл примера ).

Выведем требуемые строки на другом листе



Теперь выведем эту же таблицу на другом листе, а продажи за квартал заменим продажами нарастающим итогом .

Для этого в ячейку В6 на листе Нарастающий итог введите формулу аналогичную рассмотренной выше =ИНДЕКС(Лист1!B$8:B$17;ПОИСКПОЗ($A6;Лист1!$A$8:$A$17;0)) и скопируйте ее вниз.

А в ячейке С6 введите =ИНДЕКС(Лист1!C$8:C$17;ПОИСКПОЗ($A6;Лист1!$A$8:$A$17;0))+СУММ(B6)

Скопируем ее вниз и вправо. Получим требуемый результат.

Примечание : О том, почему в формуле использовано выражение + СУММ(B6) , а не просто +В6 читайте в этой статье .

В файле примера показано как с помощью формул вывести только четные строки или только нечетные (попробуйте это сделать Автофильтром!)


Комментарии
Только для авторизованных пользователей

(только для авторизованных пользователей)

© Copyright 2013 - 2020 Excel2.ru. All Rights Reserved