Название месяца прописью в EXCEL

Если в ячейке содержится дата или номер месяца, то с помощью формул или Формата ячейки можно вывести название месяца. Также решим обратную задачу: из текстового значения названия месяца получим его номер.


Пусть в ячейке В6 содердится дата 05.09.2016

С помощью формулы =ТЕКСТ(B6;"ММММ") можно вывести полное название месяца с заглавной буквы в именительном падеже, Сентябрь . Чтобы вывести название со строчной буквы используйте функцию СТРОЧН() .

Примечание : Результат предыдущей формулы - текстовое значение. Если нужно, чтобы в ячейке была дата, то используйте Формат ячеек (нажмите сочетание клавиш CTRL+1 ). О форматах даты подробнее можно прочитать в статье Пользовательский формат ДАТЫ и ВРЕМЕНИ в MS EXCEL

Формула =ТЕКСТ(B6;"МММ") выведет сокращенное название месяца (3 буквы).

Особый формат =ТЕКСТ(B6;"[$-FC19] ММММ") выведет полное название месяца с учетом склонения, т.е. сентября . Этот формат удобен для вывода фраз, например, Сегодня 1 сентября , но может работать не на всех компьютерах.

Если месяц задан числом от 1 до 12, то полное название можно вывести с помощью формулы =ТЕКСТ(ДАТА(;B14;1);"ММММ") . Название со склонением можно вывести с помощью формулы =ВЫБОР(B14;"января";"февраля";"марта";"апреля";"мая";"июня";"июля";"августа";"сентября";"октября";"ноября";"декабря") .

Если требуется решить обратную задачу, то есть, имея название месяца, получить его номер, то используйте формулу =МЕСЯЦ(ДАТАЗНАЧ(1&B21&2011))

Название месяца должно быть в именительном падеже и без опечаток.

Для наглядности можно составить перечень месяцев с их номерами и с помощью функции ВПР() выбирать название месяца по его номеру (см. файл примера ).


Комментарии
Только для авторизованных пользователей

Аноним, 24 августа 2016 г.
Волшебство!!! ))) спасибо за статью, все получилось!!!
Аноним, 11 февраля 2017 г.
Если в B1 стоит СЕГОДНЯ(), то не работает(
Михаил, 12 февраля 2017 г.
Вы, наверное, удалили первые 5 строк на листе файла примера и ячейка В6 стала В1. Я сделал тоже самое, у меня по прежнему все работает. Нужен файл, в котором не работает. Присылайте вопрос в группу https://vk.com/excel2ru
Аноним, 2 декабря 2017 г.
Все работает норм: =ТЕКСТ(СЕГОДНЯ(); "ММММ")
Аноним, 16 марта 2018 г.
[id1628552|Boris], спасибо!! Именно кавычки помогли
Аноним, 5 декабря 2018 г.
Везде январи получаются
Михаил, 8 декабря 2018 г.
У вас ссылка в формуле на весь столбец с датами, а нужно на ячейку
Аноним, 16 марта 2019 г.
Круто! Спасибо. Обошлись без макросов.
(только для авторизованных пользователей)

© Copyright 2013 - 2020 Excel2.ru. All Rights Reserved