Название месяца прописью в EXCEL

Если в ячейке содержится дата или номер месяца, то с помощью формул или Формата ячейки можно вывести название месяца. Также решим обратную задачу: из текстового значения названия месяца получим его номер.


Пусть в ячейке В6 содердится дата 05.09.2016

С помощью формулы =ТЕКСТ(B6;"ММММ") можно вывести полное название месяца с заглавной буквы в именительном падеже, Сентябрь . Чтобы вывести название со строчной буквы используйте функцию СТРОЧН() .

Примечание : Результат предыдущей формулы - текстовое значение. Если нужно, чтобы в ячейке была дата, то используйте Формат ячеек (нажмите сочетание клавиш CTRL+1 ). О форматах даты подробнее можно прочитать в статье Пользовательский формат ДАТЫ и ВРЕМЕНИ в MS EXCEL

Формула =ТЕКСТ(B6;"МММ") выведет сокращенное название месяца (3 буквы).

Особый формат =ТЕКСТ(B6;"[$-FC19] ММММ") выведет полное название месяца с учетом склонения, т.е. сентября . Этот формат удобен для вывода фраз, например, Сегодня 1 сентября , но может работать не на всех компьютерах.

Если месяц задан числом от 1 до 12, то полное название можно вывести с помощью формулы =ТЕКСТ(ДАТА(;B14;1);"ММММ") . Название со склонением можно вывести с помощью формулы =ВЫБОР(B14;"января";"февраля";"марта";"апреля";"мая";"июня";"июля";"августа";"сентября";"октября";"ноября";"декабря") .

Если требуется решить обратную задачу, то есть, имея название месяца, получить его номер, то используйте формулу =МЕСЯЦ(ДАТАЗНАЧ(1&B21&2011))

Название месяца должно быть в именительном падеже и без опечаток.

Для наглядности можно составить перечень месяцев с их номерами и с помощью функции ВПР() выбирать название месяца по его номеру (см. файл примера ).

© Copyright 2013 - 2020 Excel2.ru. All Rights Reserved