Максимальный по условию с выводом номера позиции в EXCEL

Файл примера

Нахождение максимального/ минимального значения - простая задача, но она несколько усложняется, если МАКС/ МИН нужно найти не среди всех значений диапазона, а только среди тех, которые удовлетворяют определенному условию. Эта задача решена в статье Максимальный и Минимальный по условию в MS EXCEL . Здесь найдем номер позиции (строки), в которой содержится это максимальное значение.

Пусть имеется таблица с тремя столбцами: текстовым и 2-мя числовыми (см. файл примера ).

Найдем максимальное значение, соответствующее Товар1 , затем определелим номер позиции (строки), в которой содержится это максимальное значение, затем выведем соответствующее значение из столбца Параметр .

Решение

Сначала сформируем список Товаров без повторов (см. статью Отбор уникальных значений (убираем повторы из списка) в MS EXCEL ).

Затем, определим максимальное количество для определенного товара (см. статью Максимальный и Минимальный по условию в MS EXCEL ).

Позицию максимального значения в столбце Всего заказов определелим с помощью формулы массива :

= НАИБОЛЬШИЙ(ЕСЛИ(($A$6:$A$18=E6)*($B$6:$B$18=F6);СТРОКА($A$6:$A$18)-СТРОКА($A$5);"");1)

Выведем значение, соответствующее максимальному значению из столбца Параметр, с помощью формулы =ИНДЕКС($C$6:$C$18;G6)


Файл примера

© Copyright 2013 - 2020 Excel2.ru. All Rights Reserved