Функция СРЗНАЧ() - Среднее арифметическое в MS EXCEL

Функция СРЗНАЧ(), английский вариант AVERAGE(), возвращает среднее арифметическое своих аргументов. Также рассмотрена функция СРЗНАЧА(), английский вариант AVERAGEA()

Пусть дана таблица значений (см. файл примера). Найдем среднее арифметическое значений ячеек таблицы.

Для решения этой задачи в EXCEL существует стандартная функция СРЗНАЧ(). Вычисления выполняются в соответствии с хорошо известной всем формулой:


где n - общее количество значений х.

Если значения расположены в диапазоне A5:A15, то формула для вычисления среднего (среднего арифметического) будет выглядеть так:

=СРЗНАЧ(A5:A15)

Функция СРЗНАЧ() может в качестве аргумента воспринимать несколько ссылок на различные диапазоны: формула =СРЗНАЧ(A5:A11;A12:A15) вернет тот же результат, что и предыдущая формула.

Если в массиве есть числа в текстовом формате

В случае, если число введено в ячейку с текстовым форматом (см. ячейку А6), то это значение воспринимается функцией СРЗНАЧ() как текст и игнорируется. Поэтому, не смотря на то, что в диапазоне A5:A15 11 значений, для функции СРЗНАЧ() их всего 10, т.е. n в этом случае =10. Среднее будет равно 20,4 (см. файл примера).

Функция СРЗНАЧA() ведет себя по другому: числа в текстовом формате интерпретируются ею как 0, впрочем, как и все остальные текстовые значения, включая значение Пустой текст "". Поэтому, для функции СРЗНАЧА() n =11, а среднее будет равно 18,545454.

Чтобы числа в текстовом формате также учитывались при вычислении среднего, то нужно записать формулу массива =СРЗНАЧ(A5:A15+0). В этом случае среднее будет равно 18,818181, т.к. n=11, а число в текстовом формате будет интерпретировано как 3.

Примечание: Чтобы перевести числа из текстового формата в числовой см. статью Преобразование ЧИСЕЛ из ТЕКСТового формата в ЧИСЛОвой (Часть 1. Преобразование формулами).

Примечание: о вычислении средневзвешенного значения см. статью Средневзвешенная цена в MS EXCEL

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 5 (4 оценок)