Функция ЕПУСТО() в EXCEL

Задача функции ЕПУСТО() , английский вариант ISBLANK(), - проверять есть ли в ячейке число, текстовое значение, формула или нет. Если в ячейке А1 имеется значение 555, то формула = ЕПУСТО(А1) вернет ЛОЖЬ, а если ячейка А1 пуста, то ИСТИНА.


Синтаксис функции ЕПУСТО()

ЕПУСТО ( значение )

Значение - значением может быть все что угодно: текст, число, ссылка, имя , пустая ячейка , значение ошибки, логическое выражение.

Использование функции



В файле примера приведены несколько вариантов проверок:

1. Если в проверяемой ячейке содержится число, текстовое значение, формула, то функция вернет логическое значение ИСТИНА.

2. Если проверяемая ячейка пуста, то функция также вернет логическое значение ЛОЖЬ.

Проверка диапазона ячеек

Функция ЕПУСТО() проверяет содержимое только одной ячейки. Чтобы подсчитать количество пустых ячеек в диапазоне, то используйте функцию СЧИТАТЬПУСТОТЫ() , но если ячейки содержат значение Пустой текст (""), то функция СЧИТАТЬПУСТОТЫ() будет подсчитывать также и эти ячейки наряду с действительно пустыми. Об этом читайте в статье Подсчет пустых ячеек .

Чтобы ответить на вопрос "Есть ли хотя бы 1 пустая ячейка в B6:B11?" используйте формулу массива

= ЕСЛИ(СУММ(--ЕПУСТО(B6:B11));ИСТИНА)

Чтобы ответить на вопрос "Есть ли хотя бы 1 заполненная ячейка в B6:B11?" используйте формулу массива

= НЕ(ЕПУСТО(B6:B11))


Комментарии
Только для авторизованных пользователей

Аноним, 16 мая 2016 г.
Почему нельзя сделать копипаст??? Боитесь воровства контента? Те, кто его ворует, обойдут вашу защиту на раз два...
Аноним, 19 мая 2016 г.
Это для собственного психологического комфорта😉
Михаил, 10 июля 2016 г.
Все формулы содержатся в файле примера.
Аноним, 11 января 2018 г.
Так тут сразу же ошибка. Функция возвращает ИСТИНА если ячейка пустая.
Михаил, 12 января 2018 г.
так и должно быть )))
Аноним, 8 февраля 2018 г.
[id43053875|Евгений], какой вы комфортный
Аноним, 31 марта 2018 г.
как проверить ячейку на содержание формулы ?
Аноним, 27 июня 2018 г.
самый простой способ скопировать контент —-> Открыть код страницы и все готово!!!
Аноним, 8 октября 2019 г.
у вас ошибка вот в этой формуле Есть ли хотя бы 1 заполненная ячейка в B6:B11? формула реагирует только на первую ячейку заданного диапазона, остальные игнорируются
Михаил, 8 октября 2019 г.
ошибка действительно есть, но она закрылась в ваших рассуждениях. Посмотрите про формулы массива. для ввода формулы нужно нажать CTRL+SHIFT+ENTER, а не просто ENTER
Аноним, 26 ноября 2019 г.
Не сказано про проверку объединённой ячейки.
Михаил, 27 ноября 2019 г.
я объединил ячейки B17 и B18 и написал формулу =ЕПУСТО(B17) Все работает. в чем вопрос?
(только для авторизованных пользователей)

© Copyright 2013 - 2020 Excel2.ru. All Rights Reserved