Функция ЕЧИСЛО() в MS EXCEL

Задача функции ЕЧИСЛО(), английский вариант ISNUMBER(), - проверять являются ли значения числами или нет. Формула =ЕЧИСЛО(5) вернет ИСТИНА, а =ЕЧИСЛО("Привет!") вернет ЛОЖЬ.

Синтаксис функции ЕЧИСЛО()

ЕЧИСЛО(значение)

Значение - значением может быть все что угодно: текст, число, ссылка, имя, пустая ячейка, значение ошибки, логическое выражение.

Использование функции

В файле примера приведены несколько вариантов проверок:

1. Если в качестве значения на вход подается число и формат ячейки НЕ был установлен Текстовый, то функция вернет логическое значение ИСТИНА. Если формат ячейки с числом изменить на Текстовый уже после того, как функция вернула значение ИСТИНА, то она не станет возвращать значение ЛОЖЬ.

2. Если в качестве значения на вход подается число и формат ячейки был установлен Текстовый (до ввода числа в ячейку), то функция вернет логическое значение ЛОЖЬ. Если формат ячейки с числом изменить на Числовой уже после того, как функция вернула значение ЛОЖЬ, то она не станет возвращать значение ИСТИНА.

Вывод: функция ЕЧИСЛО() не пытается конвертировать значения в числовой формат. Однако, ее легко заставить делать это. Если в ячейке А1 число сохранено как текст, то формула =ЕЧИСЛО(--A1) вернет ИСТИНА, а =ЕЧИСЛО(A1) - ЛОЖЬ.

3. Логические значения ЛОЖЬ и ИСТИНА формально в EXCEL числами не являются и это доказывает тот факт, что формулы =ЕЧИСЛО(ЛОЖЬ) и =ЕЧИСЛО(ИСТИНА) вернут ЛОЖЬ. Однако, значениям ЛОЖЬ и ИСТИНА сопоставлены значения 0 и 1 соответственно, поэтому формулы =ЕЧИСЛО(--ЛОЖЬ) и =ЕЧИСЛО(--ИСТИНА) вернут ИСТИНА.

4. Функция ЕЧИСЛО() обычно используется в паре с функцией ЕСЛИ(). Например, формула =ЕСЛИ(ЕЧИСЛО(B6);"Число";"Не число") вернет слово Число, если в ячейке В6 находится число (в числовом формате).

 

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 4.8 (4 оценок)