Есть ли в MS EXCEL повторы в списке?

Ответим на вопрос: Есть ли в списке значений повторы? Список может содержать пустые ячейки.

Пусть имеется список значений в диапазоне А6:А14 (не важно числовых или текстовых, список может содержать пустые ячейки).

Задача

Определим, есть ли повторы в списке.

Решение

Наличие в списке повторяющихся значений определим следующим образом: подсчитаем общее количество значений и вычтем из него количество уникальных значений. Если оба количества совпадают, то список отсутствуют повторы (см. файл примера).

Запишем формулу:
=ЕСЛИ(
СЧЁТЗ(A6:A20)-СУММПРОИЗВ((A6:A20<>"")/СЧЁТЕСЛИ(A6:A20;A6:A20&""))
;"Есть повторы!";"Нет повторов")

Формула определяет количество уникальных значений и вычитает его из общего количества значений СЧЁТЗ(A6:A20). С помощью функции ЕСЛИ(), в случае наличия повторов, формула выводит текст Есть повторы! В противном случае формула выводит Нет повторов.

Другим решением является формула массива
=МАКС(СЧЁТЕСЛИ(A6:A20;A6:A20))=1

которая возвращает ИСТИНА, если список состоит только из неповторяющихся значений (т.е. нет повторов).

Еще одним решением для списков с числами является формула =ЕСЛИ(ЕНД(МОДА(C8:C22));"Нет повторов";"Есть повторы!")

Функция МОДА() возвращает наиболее часто повторяющееся в списке значение. Если повторов нет, то она возвращает ошибку #Н/Д.

СОВЕТ:
Формула подсчета уникальных числовых значений рассмотрена в статье Подсчет уникальных числовых значений. О выделении в списке повторяющихся значений с помощью Условного форматирования можно прочитать в статье Выделение всех повторов.

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 5 (2 оценок)