Есть ли слово в списке EXCEL

Найдем слово в диапазоне ячеек, удовлетворяющее критерию: точное совпадение с критерием, совпадение с учетом регистра, совпадение лишь части символов из слова и т.д.


Пусть Список значений, в котором производится поиск содержит только отдельные слова (см. столбец А на рисунке ниже).

Совет: О поиске слова в списках, состоящих из текстовых строк (т.е. в ячейке содержится не одно слово, а несколько, разделенных пробелами) можно прочитать в статье Выделение ячеек c ТЕКСТом с применением Условного форматирования в MS EXCEL .

Задачу поиска текстового значения в диапазоне ячеек можно разбить на несколько типов:

  • ищутся значения в точности совпадающие с критерием;
  • ищутся значения содержащие критерий;
  • ищутся значения с учетом РЕгиСТра .

Ищутся значения в точности соответствующие критерию

Это простейший случай. Здесь можно использовать формулу наподобие нижеуказанной =СЧЁТЕСЛИ($A$5:$A$11;"яблоки")

Формула возвращает количество найденных значений, соответствующих критерию (см. файл примера ).

Ищутся значения содержащие часть текстовой строки



Типичный вопрос для этого типа поиска: Есть ли в Списке слово со слогом МА?

Для ответа на вопросы такого типа требуется задать в качестве критерия часть текстового значения. Например, для отбора всех ячеек, содержащих все склонения слова яблоко (яблоку, яблоком, яблока и пр.) можно использовать критерии с подстановочным знаком * (звездочка). Для этого нужно использовать конструкцию *яблок* .

Типичная формула =СЧЁТЕСЛИ($A$5:$A$11;"*МА*")

Ищутся значения с учетом РЕгиСТрА

Учет регистра приводит к необходимости создания сложных формул или использования дополнительных столбцов. Чаще всего используются формулы на основе функций учитывающих регистр НАЙТИ() , СОВПАД() .

Формула массива =ИЛИ(СОВПАД("яблоки";A5:A11)) дает ответ на вопрос есть ли такой элемент в списке.

СОВЕТ: Идеи о поиске также можно посмотреть в статье Поиск текстовых значений в списках. Часть1. Обычный поиск .

Комментарии
Только для авторизованных пользователей

Аноним, 9 июня 2018 г.
Ребята, огромное спасибо за ваш труд!!! Содержательно, структурно, доходчиво!!! Помощь в работе - колоссальная!!! Благодарю)))
(только для авторизованных пользователей)

© Copyright 2013 - 2020 Excel2.ru. All Rights Reserved