Пользовательский ЧИСЛОвой формат в MS EXCEL (Функция ТЕКСТ())

Числовой пользовательский формат – это формат отображения числа задаваемый пользователем. Например, число 5647,22 можно отобразить как 005647 или, вообще в произвольном формате, например, +(5647)руб.22коп. Пользовательские форматы также можно использовать в функции ТЕКСТ(). Эта функция возвращает текстовое значение в нужном пользователю виде.

Преобразование числа в текст может понадобиться для формирования строк, содержащих текст и числовые значения. В этом случае числу можно придать практически любой формат. Ниже приведены примеры форматов, которые можно использовать в функции ТЕКСТ().

Обычно формула выглядит так: =ТЕКСТ(1234567,8999;"# ##0,00") (не забудьте про двойные кавычки при указании формата). Результат выглядит так: 1 234 567,90. Значение в ячейке будет выравнено по левому краю (если в ячейке выравнивание по горизонтали установлено "По значению"), т.к. это текстовое значение.

Ниже приведены примеры форматирования.

Формат

Число

Результат / Комментарий

"(плю\с)# ##0,00;(\мину\с)# ##0,00;0"

5555,22

(плюс)5 555,22

"(+)# ##0,00;(–)# ##0,00;0,00"

5555,22

(+)5 555,22

"# ##0,00;# ##0,00;?"

?

?
Отображаем «другой» нуль

"# #0\ руб\.,\ 00\ коп"

1234,611

1 234 руб., 61 коп

"# ##0,0  M"
Вводить нужно так:
"#пробел##0,0двапробелаM"

1 326 666,22

1,3 М
выводит число в формате миллионов

"00000" 123 00123

"0"&СИМВОЛ(176)&"С "

13

13°С
вывод символа градуса Цельсия через его код

Необходимо помнить, что ряд букв (с м г М) и символов (*:, пробел) используются для отображения формата: с - секунда, м – минута, г – год, М – месяц. Чтобы эти символы воспринимались как обычные, а не как символы формата, не забудьте перед ними ставить обратный слеш \.

Пользовательский формат часто используется для склонения времени, например, 1 час, 2 часа, 5 часов; 1 год, 5 лет; 2 месяца, 6 месяцев. Это позволяет сделать специальный условный формат.

Например, формула склоняет сутки ="сут"&ТЕКСТ(B3;"[<2]ки ;ок ") в зависимости от количества суток в ячейке В3. Такая конструкция формата говорит функции ТЕКСТ(), что если в ячейке В3 значение менее 2, т.е. 1 сутки, то нужно использовать окончание "ки", во всех остальных случаях (больше или равно 2) нужно использовать окончание "ок", т.е. 2 суток, 3 суток и т.д.

Всего можно использовать 3 условия. Если попытаться использовать 4 и более условия, то будет возвращена ошибка #ЗНАЧ!

Такой устовный пользовательский формат можно использовать и в формате ячеек. В этом случае в ячейке, к которой применен такой формат, будет по преждему число (например 5), а на листе будет отображаться, 5 суток.

ВНИМАНИЕ!

Результат функции ТЕКСТ() – текст! Если в результате применения пользовательского формата нужно получить число, то используйте подход изложенный в статье Пользовательский числовой формат (Формат ячеек). Там же можно найти примеры других форматов.

Ниже приведены форматы, рассмотренные в файле примера.

Связанные статьи

Похожие задачи
Прочитайте другие статьи, решающие похожие задачи в MS Excel. Это позволит Вам решать широкий класс подобных задач.
Средняя: 5 (2 оценок)