Выделение в EXCEL дубликатов, встречающихся 3 или 4 раза

history

Настроим Условное форматирование для выделения повторяющихся значений, которые повторяются 3 или 4 раза.


Выделим с помощью Условного форматирования только дубликаты , которые встречаются 3 или 4 раза (см. Файл примера ).

  • Выделите диапазон содержащий список значений, например, A 3: A 16 ;
  • Вызовите Условное форматирование ( Главная/ Стили/ Условное форматирование/ Создать правило/ Использовать формулу для определения форматируемых ячеек ) ;
  • Введите формулу =СЧЁТЕСЛИ($A$3:$A$16;$A3)=4
  • Выберите нужное форматирование;
  • Нажмите ОК

Затем создадим еще одно правило:

  • Вызовите Условное форматирование ( Главная/ Стили/ Условное форматирование/ Создать правило/ Использовать формулу для определения форматируемых ячеек ) ;
  • Введите формулу =СЧЁТЕСЛИ($A$3:$A$16;$A3)=3
  • Выберите другое форматирование;
  • Нажмите ОК

Значения, повторяющиеся 3 раза, выделены красным; 4 раза – желтым.


Комментарии

Только для авторизованных пользователей

Аноним, 19 декабря 2019 г.
Здравствуйте! Подскажите как сделать если мне необходимо Выделить цветом Определенное значение и количество данных значений в диапазоне. Пример: https://docs.google.com/spreadsheets/d/1aZNZj_RsJUZsqiEuztXManb3hhLRGnc6hEGWFyhrGLU/edit?usp=sharing
Михаил, 21 декабря 2019 г.
В столбце D введите формулу =СЧЁТЕСЛИ($C$2:C2;C2)<=ВПР(C2;$A$2:$B$19;2;0) В УФ введите формулу=$D2 Или можно первую формулу ввести прямо в УФ Работает это так: -СЧЁТЕСЛИ($C$2:C2;C2) вычисляет номер повтора (сверху) -ВПР(C2;$A$2:$B$19;2;0) находит для значения максимальный номер повтора, который нужно выделять. Формула вернет номер повтора или ошибку (вся формула также вернет ошибку и значение не будет выделено) -если номер повтора не превосходит заданное значение, то значение выделяется
Аноним, 26 марта 2020 г.
[id295933596|Михаил], нужна ваша помощь по данной формуле, можем поговорить по телефону, готов оплатить услугу. Спасибо
Сергей, 24 ноября 2021 г.
Здравствуйте! Подскажите, а можно ли сделать также (выделить определенным цветом, когда от 2 до 6 повторений), только когда само название значения заранее неизвестно? и значений повторяющихся может быть несколько и по 2, и по 3 и т.д. Если можно так сделать, подскажите пожалуйста как? Заранее спасибо!
Михаил, 26 ноября 2021 г.
Здравствуйте, файл примера можно легко настроить на любое количество повторений. Вводите разные значения в столбец - получите выделение нужных повторов. Базовые (элементарные) знания по условному форматированию здесь https://excel2.ru/articles/uslovnoe-formatirovanie-v-ms-excel
Сергей, 27 ноября 2021 г.
Спасибо!
(только для авторизованных пользователей)

© Copyright 2013 - 2021 Excel2.ru. All Rights Reserved