Суммирование по модулю в EXCEL

Если в диапазоне содержатся положительные и отрицательные значения, и нужно получить сумму модулей (абсолютных величин) этих значений, то это можно сделать, записав формулу в одной ячейке.


Найти сумму модулей значений в определенном диапазоне (например, в А1:А10 ) не представляет труда, создав дополнительный столбец с формулой =ABS(A1) . Затем функцией СУММ() можно подсчитать их сумму.

Но, можно создать формулу, которая сразу же бы складывала значения по модулю - без создания дополнительного столбца. Эта формула =СУММПРОИЗВ(ABS(A1:A10)) .

Другой вариант суммирования предполагает использование формулы массива =СУММ(ABS(A1:A10)) . После ввода формулы, нужно вместо ENTER нажать CTRL + SHIFT + ENTER .


© Copyright 2013 - 2020 Excel2.ru. All Rights Reserved