Сравнение числовых столбцов

Сравним 2 столбца значений. Сравнение будем производить построчно: если значение во втором столбце больше, чем в первом, то оно будет выделено красным, если меньше - то зеленым. Выделять ячейки будем Условным форматированием.


Пусть имеется 2 столбца с числами. Сравним значения второго столбца с первым (см. файл примера ).

Выделите все значения из второго столбца и создайте правило Условного форматирования для выделения меньших значений.

Обратите внимание, что при создании ссылки на ячейку из первого столбца использована относительная адресация на строку, т.е. =$A6 , а не =$A$6 , которая предлагается MS EXCEL по умолчанию. Такая адресация позволяет построчно сравнивать столбцы, в противном случае все значения второго столбца будут сравниваться только со значением из ячейки А6 .

Аналогично создайте правило для значений, которые больше.


Комментарии
Только для авторизованных пользователей

Аноним, 5 января 2018 г.
Спасибо, полезно.
Аноним, 27 марта 2020 г.
Спасибо! Очень полезно!
Аноним, 27 апреля 2020 г.
А если 3 столбца и много строк. Каждая строка отдельная позиция для сравнения. Какую формулу применить?
Михаил, 27 апреля 2020 г.
Напишите формулу =И(A1=B1;B1=C1) Она вернет ИСТИНА, если только все значения равны между собой
Михаил, 27 апреля 2020 г.
Можете использовать Спарклайны, чтобы наглядно видеть сразу 3 значения в строке https://excel2.ru/articles/sparklayny-otslezhivaem-tendencii-v-ryadah-dannyh-v-ms-excel
Аноним, 16 мая 2020 г.
А как вывести результаты сравнения в другой столбец?
Михаил, 18 мая 2020 г.
Формулу из условного форматирования (A6<B6) можно перенести в соседний столбец. Она будет возвращать значения ИСТИНА или ЛОЖЬ в зависимости от результатов сравнения: ИСТИНА, если A6<B6.
Аноним, 10 августа 2020 г.
Доброго времени суток! Подскажите как сделать так, если два столбца содержат даты, и если 1столбец больше определённого времени 2 столбца, то вывести значение на 3 столбец ?
Михаил, 10 августа 2020 г.
Здравствуйте, Статья вообще не про это, но формула вот: =ЕСЛИ(A6>B6;A6) Вы не написали, что делать, если дата меньше или равна, поэтому в этом случае формула просто вернет ЛОЖЬ
(только для авторизованных пользователей)

© Copyright 2013 - 2020 Excel2.ru. All Rights Reserved