Создание списка неповторяющихся значений в EXCEL

Файл примера

Разрешим ввод в столбец только неповторяющихся  значений.


Создадим в диапазоне А6:A19 список, состоящий только из неповторяющихся значений (см. файл примера ).

  • выделите диапазон А6:A19 ;
  • вызовите инструмент Проверка данных ( Данные/ Работа с данными/ Проверка данных );
  • на вкладке Параметры выберите тип данных Другой ;
  • в поле Формула введите: =СЧЁТЕСЛИ($A$6:$A$19;A6)<2
  • нажмите ОК.

В формуле использована относительная адресация , поэтому при вводе формулы важно какая ячейка является активной ( A6 ). Адрес активной в данный момент ячейки отображается в поле Имя , слева от Строки формул .

Если ввести в ячейку A10 фамилию-повтор Козлов, то появится диалоговое окно:

Недостаток. При создании списка этим методом можно оставлять пропуски, что нежелательно для дальнейшей работы со списками.

Чтобы запретить пропуски в диапазоне нужно изменить формулу: =И(СЧЁТЕСЛИ($A$6:$A$19;A6)<2;СЧЁТЕСЛИ($A$6:A6;"")=0)

СОВЕТ: Для визуального контроля уникальности вводимых значений можно использовать идеи из статьи Выделение повторяющихся значений .

В случае, если необходимо обеспечить ввод неповторяющихся строк, то читайте статью Создание таблиц с неповторяющимися строками .

В случае, если необходимо обеспечить ввод неповторяющихся значений с помощью Выпадающего (раскрывающегося) списка , то читайте статью Создание списка неповторяющихся значений с использованием ранее определенного списка .

Файл примера

© Copyright 2013 - 2020 Excel2.ru. All Rights Reserved